Bug 142712 - [indic]unable to display numeric characters during input
[indic]unable to display numeric characters during input
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
: 174970 (view as bug list)
Depends On:
Blocks: Indic 156322 164276 206420
  Show dependency treegraph
 
Reported: 2004-12-13 04:25 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2005-665
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 12:30:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 41672 None None None Never
OpenOffice.org 45644 None None None Never

  None (edit)
Description Lawrence Lim 2004-12-13 04:25:36 EST
Description of problem:
In the indic locale, when entering numeric characters when Input
Method is turned off, the numeric characters cannot be seen.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-17.6.EL4

How reproducible:
Always

Steps to Reproduce:
1.LANG=hi_IN.UTF-8 ooimpress
2.AutoPilot Presentation, proceed with all the default options
3.Select "Empty Presentation" (default) and click Next
4.Click Next at the slide design leaving everything as default
5.Click Next at the slide transition with everything as default
6.Click Create
7.Click OK at the "AutoLayout"
8.enter "123abc"   

Actual results:
Unable to see the numeric characters entered

Expected results:
Should be able to see the numeric characters entered

Additional info:
Affects all 5 Indic locale.
Comment 1 Lawrence Lim 2004-12-16 01:30:22 EST
Bug still exist in openoffice.org-i18n-1.1.2-18.6.EL4
Comment 2 Leon Ho 2005-01-27 15:24:30 EST
Still exist in 1.1.3-2.5. Would it be because Indic fonts does not
have numeric glyphs?
Comment 3 Lawrence Lim 2005-03-01 04:08:54 EST
Dan,
Tried with the libvcl645li.so file you gave me yesterday.
Unfortunately, the bug still exist with the .so file.


Thanks,
Lawrence
Comment 4 Caolan McNamara 2005-03-21 07:19:48 EST
Still strange with 1.9.84-1
Comment 5 Caolan McNamara 2005-06-14 19:25:43 EDT
dan has done some glyph fallback stuff for 2.0, can you try with OOo 1.9.109-4
or above from rawhide/fc4-update-candidate and verify that it's working.
Comment 6 dff 2005-06-15 04:14:54 EDT
PM ACK for U2.
Comment 8 Caolan McNamara 2005-06-15 10:57:16 EDT
This is something to do with the code behind tools->options->Complex Text
Layout->Numerals I actually thing. Will look for the bit to backport.
Comment 9 Lawrence Lim 2005-06-15 19:40:45 EDT
Tested with openoffice.org-core-1.9.109-5.1.0.fc4, numeric characters are now
able to display during input.
Comment 10 Caolan McNamara 2005-06-16 10:54:20 EDT
*** Bug 157915 has been marked as a duplicate of this bug. ***
Comment 13 Lawrence Lim 2005-06-20 21:20:02 EDT
Tested with dist/4E-scratch/openoffice.org/1.1.2-26.6.0.EL4, the fix is looking
great for all 5 indic locale. :-)


Thanks!
Comment 15 Caolan McNamara 2005-07-27 04:31:21 EDT
1.1.2-28.6.0.EL4
Comment 16 Red Hat Bugzilla 2005-10-05 12:27:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-665.html
Comment 17 Red Hat Bugzilla 2005-10-05 12:30:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-665.html
Comment 18 Caolan McNamara 2005-12-20 04:04:16 EST
*** Bug 174970 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.