Bug 17499 - X Hangs on Banshee
Summary: X Hangs on Banshee
Status: CLOSED DUPLICATE of bug 18810
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-14 13:06 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 23:36:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-14 13:06:52 UTC
Using a clean installation of Pinstripe on the following hardware:

Abit BP6
2x Celerons@600MHz
160Mb RAM
Creative Banshee
Hollywood+ MPEG2 decoder
RTL8139 NIC
SB Live

The system boots fine, allows me to log on then run 'startx'.
X Starts up, Gnome starts, and then the machine hangs.  This *seems* to be
happening when the gnome startup get to 'rm'?  There's nothing in the X
log, and the config file seems to be using the tdfx module, which I believe
to be correct.

Comment 1 Need Real Name 2000-09-15 09:07:08 UTC
Additional:

It may not be a gnome issue.  gdm starts up fine and running kde from that also
crashes.

I've narrowed it down to one of 2 things:
USB stuff
Network stuff (there's currently nothing plugged into the network card)

I've got it to run with modules for both rmmod'ed and khupd killed

Booting 2.4.0-pre5 enables X to run fine.

Comment 2 Alan Cox 2000-09-16 23:15:15 UTC
Reassigning to kernel for the moment

Does the USB and the graphics card share an IRQ line ?


Comment 3 Mike A. Harris 2001-08-09 19:02:03 UTC
This is a Voodoo Banshee XFree86 problem caused by X changing the
video timing, however different Banshee cards use different timing
and it is not easily possible to differentiate the different hardware.
This is fixed in XFree86-4.1.0-0.9.11 in rawhide now by removing
the code which handles video timing, and just leaving it to the
BIOS default.

*** This bug has been marked as a duplicate of 18810 ***


Note You need to log in before you can comment on or make changes to this bug.