Bug 18810 - Voodoo Banshee support by XFree86 is broken
Voodoo Banshee support by XFree86 is broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 17499 39148 44907 47343 51252 52951 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 09:34 EDT by Alex Malmyguine
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 10:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Malmyguine 2000-10-10 09:34:59 EDT
First, I am unable to install in graphics mode: screen is badly corrupt, 
no GUI controls visible. Setup is able to run but it's impossible to 
operate it.
Text mode setup of XFree86 recognizes Voodoo banshee and installs. When 
trying to run X aftewards, I am experiencing a number of bugs:

1. Corrupt display: GUI controls invisible, only bitmaps displayed 
correctly. Window border exists but not window content and not window 
buttons.
2. Switching resolution occurs but the next 10-15 seconds computer does 
not responds and finally hangs. No response to Ctrl-Alt-BkSpace.
3. X can even hang unpredictably upon startup.

The bug was first experienced in RedHat 6.1, reported in 6.2 and never 
fixed. In fact I am unable to run X at all that's why high prioirity and 
high severity.
Comment 1 Geoff Reedy 2000-10-19 16:52:31 EDT
If you have a Creative Labs 3D Blaster Banshee AGP, there are some issues
between the hardware (specifically the SGRAM) and the driver.  There are working
drivers on http://linux.3dfx.com/ but you cannot use the drivers there that are
based on XFree86-4.x. The modifications that these drivers incorporate have not
been incorporated back into XFree86 for whatever reason.  If this is indeed the
problem that you are having and would like some help in setting up the drivers
from linux.3dfx.com since there aren't any instructions there for redhat-7.0
send me an email and I would be glad to help.
Comment 2 Alex Malmyguine 2000-10-20 00:19:22 EDT
No, that was not Creative 3d blaster:
Video board is ASUS AGP-V3200 with 16 MB SGRAM.
CPU: Intel Celeron 333 at 300-333 MHz.
ACorp 440LX motherboard. 64 MB PC100 RAM.
Comment 3 n3m3sis 2000-10-22 03:57:58 EDT
I too have had this problem on my Banshee's since RH 6.1 and have tried most of
the custom X servers (3dfx and Creative drivers/servers) and none of them fixed
the random resolution changes... XFree86 4.0.1 does not fix the bug and the
bug also appears in UniX (as the bug is in the XFree86 server).

The problem is "not" limited to the creative cards as some report, it appears
that many of the generic cards have this problem.

Unfortunatly this bug prevents the user from entering X at all..... this is a
high priority bug and i look forward to its fix....

My system specs:
-----------
Skywell and STB AGP Banshee
Celeron 400
Kernel 2.2.17
XFree86 3.3.6 (also tried 4.0.1, 3.3.6, and Creative/3dfx servers)
-----------
Comment 4 Need Real Name 2000-10-22 04:52:56 EDT
From what i can figure out the bug is in the XFree86 drivers because now that i 
have changed over to freebsd i still have the problem it seem to affect the 
video modes dose all sorts of things from shake video at hi rez of 
1280x1024/70hz and i know its not the card of my monitor or vidcard because it 
works fine in Windows 2000 at that and higher rez. I think that the Severity of 
this bug is very high and will affect lots of new Redhat users and should be 
fixed a.s.a.p seeing that it has been a problem since Redhat 6.1 and so that 
people with a Banshee can enjoy Linux/Unix beyond the console. I have also 
experanced some of the problems of the other bug reporters.

                    My System
|-------------------------------------------------------|
|Lightspeed 3300 STB AGP Banshee                        |
|P3 500 Running at 560Mhz 112Mhz FSB                    |
|256Mb Ram                                              |
|Abit BH6 MB                                            |
|Was running Redhat 6.2 now using FreeBsd 4.1.1 Stable  |
|XFree86 4.0.1 using the tdfx driver                    |
|-------------------------------------------------------|

THX Tristan
Comment 5 n3m3sis 2000-10-23 03:23:39 EDT
After more testing and upgrading kernels to 2.4 test 9 i have discovered that
when the bug occurs (resolution incorrect/invalid) if one kills the X server
CTRL+ALT+BACKSPACE and is returned to the console (screen does not return
however, all is black) and one tries to re-enter X all returns to a working
state (screen comes back from state of blackness).....

This is interesting in that the banshee can be recovered -previously untested (i
think)- and shows that the X server must place the banshee in an incorrect
mode/state which causes the card to hang..... However if the X server is
reinitialised the screen returns from a state of darkness (however the error
randomly reoccurs and one must repeat this step).

I hope this helps people to correct the bug..... -n3m3sis
Comment 6 Alex Malmyguine 2000-10-29 23:50:03 EST
Noticed that there is dependancy between the CPU clock speed and degree of 
screen corruption. For my configuration minimum speed is 300 MHz CPU at 50 MHz 
bus at which more screen objects displayed correctly than at nominal 333 CPU 
and 66 bus. Overclocking further makes screen slightly worse but not 
proportionally to the clock speed: there is barely visual difference between 
onscreen display at 343 and 375 MHz (68 and 75 MHz bus).
Comment 7 n3m3sis 2000-11-01 01:26:37 EST
Ok this might help some people this person claims to have fixed the SNOW problem
(this does not seem to work for me... makes it worse but its at least he is
trying)

http://www.cs.sunysb.edu/~giri/xfree86-3.3.6.html

This reportedly works on SOME banshees (not mine) however the creator is very
helpful and responds quickly to emails so it shows good promise..... There is
also an XF 4.0.1 fix so i am going to try that out very shortly.

have a good one -n3m3sis


Comment 8 Mike A. Harris 2001-02-19 09:40:20 EST
A patch to fix the banshee has been added to my latest build, and
will appear in rawhide soon now (a week or so).
Comment 9 Mike A. Harris 2001-02-19 09:41:06 EST
A patch to fix the banshee has been added to my latest build, and
will appear in rawhide soon now (a week or so).
Comment 10 Mike A. Harris 2001-07-17 10:18:26 EDT
*** Bug 47343 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2001-07-17 10:20:57 EDT
*** Bug 39148 has been marked as a duplicate of this bug. ***
Comment 12 Mike A. Harris 2001-07-17 10:33:49 EDT
Ok everyone, we have an aparent fix for this longstanding banshee problem.
It is in rawhide XFree86-4.1.0-0.9.0 and later.  Can you all please try this
release and update the bug report on wether or not the Banshee works ok for
you now?  I've gotten back a couple good reports from the community in email
so far, so it looks good.
Comment 13 Mike A. Harris 2001-08-08 09:19:53 EDT
I got a banshee loaner, tested it, it works.  I received no feedback
from above, but have recieved feedback via email from people that it
works.  I assume silence == it works for everyone else too, and
everyone is so happy that they're playing Quake III instead of
bug report updating.  <grin>
Comment 14 Mike A. Harris 2001-08-09 13:06:05 EDT
*** Bug 51252 has been marked as a duplicate of this bug. ***
Comment 15 Mike A. Harris 2001-08-09 15:01:59 EDT
*** Bug 17499 has been marked as a duplicate of this bug. ***
Comment 16 Mike A. Harris 2001-08-09 15:03:40 EDT
*** Bug 44907 has been marked as a duplicate of this bug. ***
Comment 17 Mike A. Harris 2002-02-03 09:03:12 EST
*** Bug 52951 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.