Bug 175041 - Installer failed to notify kernel of changes to /dev/hda2
Installer failed to notify kernel of changes to /dev/hda2
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 17:33 EST by Daniel Spiewak
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-06 09:50:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Spiewak 2005-12-05 17:33:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I've now attempted to run the Fedora installer on four different systems (almost identical hardware).  Each time, the anaconda installer fails giving me an error message saying that the kernel can't be notified or something like that, then it fails out saying that it couldn't notify the kernel of the changes to /dev/hda2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Click through the installer using all defaults
2. Click 'Ignore' in the error message
3.
  

Actual Results:  The installer crashed

Expected Results:  The installer should have installed fedora core

Additional info:

anacdump.txt (truncated)

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
    disk.commit()
error: Error: Error informing the kernel about modifications to partition /dev/hda2 - Device or resource busy.  This means Linux won't know about any changes you made to /dev/hda2 until you reboot - so you shouldn't mount it or use it in any way before rebooting.

Local variables in innermost frame:
self: <partedUtils.DiskSet instance at 0xb7cd08ac>
disk: <PedDisk object at 0xb7efcf08>


Package Group selection status:
ISO8859-9 Support: 0
Office/Productivity: 1
Compatibility Arch Development Support: 0
Engineering and Scientific: 0
MySQL Database: 0
Development Libraries: 0
Malay Support: 0
Portuguese Support: 0
Editors: 1
System Tools: 0
Japanese Support: 0
Hungarian Support: 0
Punjabi Support: 0
British Support: 0
Korean Support: 0
GNOME Software Development: 0
German Support: 0
Gaelic Support: 0
Faeroese Support: 0
Swedish Support: 0
Server: 0
Russian Support: 0
Text-based Internet: 1
Serbian Support: 0
KDE: 0
Gujarati Support: 0
Catalan Support: 0
Lithuanian Support: 0
X Software Development: 0
Workstation Common: 0
Legacy Network Server: 0
x86 Compatibility Arch Support: 0
GNOME Desktop Environment: 1
Dialup Networking Support: 1
Turkish Support: 0
Arabic Support: 0
Basque Support: 0
Everything: 0
Core: 0
Authoring and Publishing: 0
Irish Support: 0
Italian Support: 0
Slovak Support: 0
Base: 1
Slovenian Support: 0
FTP Server: 0
Java: 0
Network Servers: 0
Kannada Support: 0
GNOME: 0
Breton Support: 0
Romanian Support: 0
Games and Entertainment: 1
Greek Support: 0
Compatibility Arch Support: 0
Zulu Support: 0
Miscellaneous Included Packages: 0
Danish Support: 0
Afrikaans Support: 0
Legacy Software Development: 0
Brazilian Portuguese Support: 0
Cyrillic Support: 0
Welsh Support: 0
Thai Support: 0
Java Development: 0
Emacs: 0
Tamil Support: 0
Legacy Software Support: 0
Windows File Server: 0
X Window System: 1
Chinese Support: 0
Graphics: 1
Web Server: 0
Ruby: 0
Czech Support: 0
Bulgarian Support: 0
Indonesian Support: 0
Eclipse: 0
Galician Support: 0
Dutch Support: 0
Printing Support: 1
KDE Software Development: 0
Icelandic Support: 0
Ukrainian Support: 0
Assamese Support: 0
KDE (K Desktop Environment): 0
Bengali Support: 0
Mail Server: 0
Spanish Support: 0
Hebrew Support: 0
Estonian Support: 0
French Support: 0
Server Configuration Tools: 0
Croatian Support: 0
Language Support: 0
PostgreSQL Database: 0
Finnish Support: 0
Norwegian Support: 0
Administration Tools: 1
Polish Support: 0
News Server: 0
Hindi Support: 0
DNS Name Server: 0
Development Tools: 0
Sound and Video: 1
Graphical Internet: 1
ISO8859-2 Support: 0


Individual package selection status:
4Suite: 0, Canna: 0, Canna-devel: 0, Canna-libs: 0, ElectricFence: 0, GConf: 0, GConf-devel: 0, GConf2: 1, GConf2-devel: 0, GFS: 0, GFS-kernel: 0, GFS-kernel: 0, GFS-kernel-smp: 0, GFS-kernel-xen0: 0, GFS-kernel-xenU: 0,
Comment 1 Chris Lumens 2005-12-06 09:50:59 EST

*** This bug has been marked as a duplicate of 160693 ***

Note You need to log in before you can comment on or make changes to this bug.