Bug 1751026 - Not giving proper error message when trying to create new instance with same instance name/ports
Summary: Not giving proper error message when trying to create new instance with same ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
: 1751100 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 04:10 UTC by Madhuri
Modified: 2019-11-06 12:42 UTC (History)
9 users (show)

Fixed In Version: 389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 12:42:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot containing the same intace name and port number that is already present (154.82 KB, image/png)
2019-09-11 09:05 UTC, aman dwivedi
no flags Details
The message it is showing is "Failed to create instance!" not specifing the actual error (146.26 KB, image/png)
2019-09-11 09:09 UTC, aman dwivedi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3731 None None None 2019-11-06 12:42:45 UTC

Description Madhuri 2019-09-11 04:10:53 UTC
Description of problem:
Not giving proper error message when trying to create new instance with same instance name/port/ssl port


Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1. Create instance with name test
2. Now again try to create new instance with same name but different ports
3.

Actual results:
showing error message
'Failed to create instance!'

Expected results:
Should show error message with reason to fail to create new instance. 

Additional info:

Comment 2 aman dwivedi 2019-09-11 09:05:21 UTC
Created attachment 1614001 [details]
Screenshot containing the same intace name and port number that is already present

Comment 3 aman dwivedi 2019-09-11 09:09:15 UTC
Created attachment 1614003 [details]
The message it is showing is "Failed to create instance!" not specifing the actual error

Comment 4 mreynolds 2019-09-12 20:43:02 UTC
*** Bug 1751100 has been marked as a duplicate of this bug. ***

Comment 6 Viktor Ashirov 2019-10-29 21:17:16 UTC
Builds tested:
389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.x86_64
cockpit-389-ds-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.noarch

I see the following messages when I try to use the same port as another instance:

For non-secure port:
Starting installation...
Error: port 389 is already in use, or missing NET_BIND_SERVICE

For secure port:
Starting installation...
Error: secure_port 636 is already in use, or missing NET_BIND_SERVICE


Marking as VERIFIED.

Comment 8 errata-xmlrpc 2019-11-06 12:42:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3731


Note You need to log in before you can comment on or make changes to this bug.