Bug 1751100 - New instance creation fails with certain ports numbers
Summary: New instance creation fails with certain ports numbers
Keywords:
Status: CLOSED DUPLICATE of bug 1751026
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 07:39 UTC by rmitra
Modified: 2019-09-12 20:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-12 20:43:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description rmitra 2019-09-11 07:39:30 UTC
Description of problem
======================
New instance creation fails when using certain port numbers even if those ports are currently not under use. For eg, port numbers 300/400/... or 3000/6000/... fails with blank errors but other port numbers like 1100, 1200, etc have no issues.


Version-Release number of selected component (if applicable)
============================================================
RHDS 11
389-ds-base.x86_64-1.4.1.8-1


How reproducible
================
From cockpit webUI, Actions --> create instance --> enter all details including port number = 300 or 400 or similar. Instance creation fails with blank error.


Steps to Reproduce
==================
1.
2.
3.

Actual results
==============
Instance creation fails only with certain ports numbers such as 300, 400, ... or  3000, 4000, etc, even if these ports are not in use, mostly because these are reserved ports.


Expected results
================
Appropriate error message should be displayed in case the port numbers specified are reserved ports.

Something similar to:

Error: Port 600 was already labeled with: (hi_reserved_port_t)  Please choose a different port number, removing incomplete installation... Error: Instance creation failed!


Additional info
===============

Comment 1 Vinay Mishra 2019-09-11 21:26:24 UTC
Hello Team,

Getting error as below:
~~~
[root@ci-vm-10-0-133-194 ~]# tail -f /var/log/messages 
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.589147741 -0400] - NOTICE - ldbm_back_start - cache autosizing: userRoot dn cache (1 total): 65536k
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.589925343 -0400] - NOTICE - ldbm_back_start - total cache size: 189363650 B;
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.591881172 -0400] - ERR - attrcrypt_cipher_init - No symmetric key found for cipher AES in backend userRoot, attempting to create one...
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.595150769 -0400] - INFO - attrcrypt_cipher_init - Key for cipher AES successfully generated and stored
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.595829184 -0400] - ERR - attrcrypt_cipher_init - No symmetric key found for cipher 3DES in backend userRoot, attempting to create one...
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.598967941 -0400] - INFO - attrcrypt_cipher_init - Key for cipher 3DES successfully generated and stored
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.687079183 -0400] - INFO - slapd_daemon - slapd started.  Listening on All Interfaces port 389 for LDAP requests
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.698174681 -0400] - INFO - slapd_daemon - Listening on All Interfaces port 636 for LDAPS requests
Sep 11 17:16:17 rhds-test-day2-10 ns-slapd[10084]: [11/Sep/2019:17:16:17.709168626 -0400] - INFO - slapd_daemon - Listening on /var/run/slapd-test.socket for LDAPI requests
Sep 11 17:16:17 rhds-test-day2-10 systemd[1]: Started 389 Directory Server test..
Sep 11 17:17:52 rhds-test-day2-10 systemd[1]: Reloading.
Sep 11 17:17:52 rhds-test-day2-10 systemd[1]: /usr/lib/systemd/system/rngd.service:7: Unknown lvalue 'Grou' in section 'Service'
Sep 11 17:17:56 rhds-test-day2-10 systemd[1]: Reloading.
Sep 11 17:17:56 rhds-test-day2-10 systemd[1]: /usr/lib/systemd/system/rngd.service:7: Unknown lvalue 'Grou' in section 'Service'
Sep 11 17:20:44 rhds-test-day2-10 systemd[1]: Starting dnf makecache...
~~~

Thanks
Vinay

Comment 2 mreynolds 2019-09-12 20:43:02 UTC
This is being fixed in BZ#1751026, closing as a duplicate

*** This bug has been marked as a duplicate of bug 1751026 ***


Note You need to log in before you can comment on or make changes to this bug.