Bug 1751557 - syncop: Bail out if frame creation fails
Summary: syncop: Bail out if frame creation fails
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-12 07:28 UTC by Soumya Koduri
Modified: 2019-09-23 07:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-23 07:06:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 23404 0 None Merged core/syncop: Bail out if frame creation fails 2019-09-23 07:06:03 UTC

Description Soumya Koduri 2019-09-12 07:28:24 UTC
This bug was initially created as a copy of Bug #1748448

I am copying this bug because: 



Description of problem:

There could be cases (either due to insufficient memory or
corrupted mem-pool) due to which frame creation fails. Bail out
with error in such cases.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-09-12 07:33:00 UTC
REVIEW: https://review.gluster.org/23404 (core/syncop: Bail out if frame creation fails) posted (#1) for review on release-6 by soumya k

Comment 2 Worker Ant 2019-09-23 07:06:04 UTC
REVIEW: https://review.gluster.org/23404 (core/syncop: Bail out if frame creation fails) merged (#2) on release-6 by hari gowtham


Note You need to log in before you can comment on or make changes to this bug.