Bug 175175 - system-config-lvm hangs forever when making large logical volume
system-config-lvm hangs forever when making large logical volume
Status: CLOSED DUPLICATE of bug 167847
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 06:21 EST by birger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 13:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description birger 2005-12-07 06:21:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
I have created a new logical volume and selected ext3 file system.
I saw the mkfs.ext3 process running actively for some time, but now it's idling, and never finishes. I have done this twice, so it is repeatable..

strace -p <pid of mkfs.ext3> gives only this:
write(1, "3632/4000", 9 <unfinished ...>

Could it be that when making a large file system mkfs hangs because the pipe to system-config-lvm fills up? Doesn't system-config-lvm poll the pipe until the mkfs process finishes? I can mkfs the volume manually without any problems.

I am creating a 0.5TB file system on a 1.3TB physical volume.

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.32-1.0

How reproducible:
Always

Steps to Reproduce:
1. Create very large volume group (in my case a 1.3TB partition from a raid controller)
2. Create a large logical volume (in my case a 0.5TB partition)
3. Select to have it created with ext3 file system
  

Actual Results:  The volume gets created, mkfs.ext3 runs for a while, then idles

Expected Results:  Should have finished making the file system and mounted it

Additional info:

This server runs from a raid controller with 4 0.5TB disks in raid5. The raid set is partitioned in /, /var, swap and a large data partition. The data partition is used as the physical volume in lvm.
Comment 1 Stanko Kupcevic 2005-12-19 13:51:44 EST

*** This bug has been marked as a duplicate of 167847 ***

Note You need to log in before you can comment on or make changes to this bug.