Bug 175178 - Remove perl-dependency
Remove perl-dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aspell (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
: FutureFeature, Reopened
: 189664 197439 202359 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 07:45 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 10:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2005-12-07 07:45:21 EST
Description of problem:

RPM creates an automatic perl-dependency for aspell. This dependency is caused
only by /usr/bin/aspell-import which is not needed for core functionality.

Because perl is a huge package it would be nice when this requirement would be
remove from the 'aspell' package.

Ways would be:

* move non-core tools (e.g. aspell-import, precat, pre*zip, ...) into a -tools 
  subpackage
* move libs into a -lib subpackage so that e.g. 'php' would require aspell-libs 
  instead of a bloaty 'aspell'
* do not package 'import-aspell'
* move 'import-aspell' into %doc section and remove x-permissions


Version-Release number of selected component (if applicable):

aspell-0.60.3-2
Comment 1 Ivana Varekova 2005-12-14 04:12:28 EST
Hello,
perl is quite common package and it is needed by many other packages so I think
it is better to leave aspell with perl dependency.
 
Comment 2 Enrico Scholz 2005-12-14 04:30:04 EST
> perl is quite common package

not here. On most of my machines, perl is installed only because of bad
packaging. Why do you want to introduce this huge dependency for people who do
not need perl when there exist simple ways to avoid it?

Comment 3 Enrico Scholz 2006-01-03 12:33:18 EST
can we fix this before the FC5Test2 freeze at 2005 Jan 09, please?
Comment 4 Enrico Scholz 2006-02-04 11:38:58 EST
ping
Comment 5 Ivana Varekova 2006-04-24 05:12:40 EDT
*** Bug 189664 has been marked as a duplicate of this bug. ***
Comment 6 Ivana Varekova 2006-07-04 08:19:21 EDT
*** Bug 197439 has been marked as a duplicate of this bug. ***
Comment 7 Ivana Varekova 2006-08-14 02:40:49 EDT
*** Bug 202359 has been marked as a duplicate of this bug. ***
Comment 8 Red Hat Bugzilla 2007-02-05 14:26:16 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 9 Ivana Varekova 2007-05-21 10:08:21 EDT
Fixed if aspell-0.60.5-3.fc7.

Note You need to log in before you can comment on or make changes to this bug.