Bug 189664 - Remove perl-dependency
Remove perl-dependency
Status: CLOSED DUPLICATE of bug 175178
Product: Fedora
Classification: Fedora
Component: aspell (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-22 08:08 EDT by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 05:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2006-04-22 08:08:12 EDT
Description of problem:

RPM creates an automatic perl-dependency for aspell.  On most of my machines, 
perl is installed only because of bad packaging but not, because it is needed.

This dependency on perl is caused only by /usr/bin/aspell-import which is not 
needed for core functionality.

Because perl is a huge and usually unneeded package it would be nice when this 
requirement would be removed from the 'aspell' package.

Ways would be:

* move non-core tools (e.g. aspell-import, precat, pre*zip, ...) into a -tools 
  subpackage
* move libs into a -lib subpackage so that e.g. 'php' would require aspell-libs 
  instead of a bloaty 'aspell'
* do not package 'import-aspell'
* move 'import-aspell' into %doc section and remove x-permissions


Version-Release number of selected component (if applicable):

aspell-0.60.3-5


How reproducible:

100%


Steps to Reproduce:
0. rpm -Uvh --root `pwd`/test fedora-release-5-5.noarch.rpm --nodeps
   # not really needed but helps with yum
2. yum --installroot `pwd`/test php
3. rpm -e --root `pwd`/test perl
  

Actual results:

'perl' is installed and required only by 'aspell'

| $ rpm -e --root `pwd`/test perl
| error: Failed dependencies:
|         /usr/bin/perl is needed by (installed) aspell-0.60.3-5.i386
| $

--> 'aspell' is the only package requiring 'perl'


Expected results:

'perl' would not have been installed during 2) because 'perl' is not required to
make 'aspell' work.
Comment 1 Ivana Varekova 2006-04-24 05:12:18 EDT

*** This bug has been marked as a duplicate of 175178 ***

Note You need to log in before you can comment on or make changes to this bug.