Bug 175181 - Anaconda bombs in linux rescue mode
Anaconda bombs in linux rescue mode
Status: CLOSED DUPLICATE of bug 172588
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-12-07 08:47 EST by David Tonhofer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-07 10:26:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2005-12-07 08:47:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
* Boot system with first RH ES 4 installation CD
* Type linux rescue
* When the screen comes up that tells you to configure networking,
  say 'yes', then configure (in my case 2) interfaces manually (I set
  both interfaces to a 192.168.1.* private address.
* Get out of screen.
* Anaconda bombs (screen colors are white on blue), Here is what is on screen:

Traceback (most recent call last, kinda hard to read because the CR characters seem to be missing in the output):

File "/usr/bin/anaconda", line 604, in ?
rescue.runRescue(rootPath, not rescue_nomount, id)
File "/usr/lib/anaconda/rescue.py", line 209, in runRescue
rc = apply(win, (screen, ) + args)
TypeError: __call__() takes exactly 6 arguments (5 given)

Interleaved, this text:

install exited abnormally
sending termination signals...done
sending kill signals...done
etc. until
you may safely reboot your system

Version-Release number of selected component (if applicable):
RH ES 4 ISO images, update 2

How reproducible:
Didn't try

Steps to Reproduce:
See above  

Actual Results:  See above

Expected Results:  See above

Additional info:
Comment 1 Paul Nasrat 2005-12-07 10:26:10 EST

*** This bug has been marked as a duplicate of 172588 ***

Note You need to log in before you can comment on or make changes to this bug.