This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 175303 - what to do about widescreen monitors and the default background...
what to do about widescreen monitors and the default background...
Status: CLOSED DUPLICATE of bug 176371
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 177176 (view as bug list)
Depends On:
Blocks: FC6Target FC6Desktop
  Show dependency treegraph
 
Reported: 2005-12-08 12:53 EST by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 15:00:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testimage.svg (1.82 KB, image/svg+xml)
2006-02-01 23:19 EST, Matthias Clasen
no flags Details
image1.png (1.86 KB, image/png)
2006-02-01 23:21 EST, Matthias Clasen
no flags Details
image2.png (296 bytes, image/png)
2006-02-01 23:22 EST, Matthias Clasen
no flags Details

  None (edit)
Description Jeremy Katz 2005-12-08 12:53:36 EST
As widescreen monitors get more common, stretching of the background makes
things look less than ideal.  We should probably try to do something more
intelligent
Comment 1 Ray Strode [halfline] 2005-12-08 13:14:37 EST
I wonder if SVG supports hinting for graceful changes in aspect ratio...

Otherwise, maybe we could make the default have nothing complicated at the edges
(logos, gradients, etc) and just paint the vertical bars on the side the same 
color as the background.

If we could tweak the image in the default install then that's the easiest way.
 Otherwise we have to come up with some sort of matching heuristics to figure
out which image to load.

Coming up with a non-hacky solution for this type of problem is actually sort of
hard.
Comment 2 Jeremy Katz 2005-12-08 14:01:57 EST
Tweaking the image at the install is poor because it won't adapt nicely to
changed monitors or things like remote X.  Also, we don't know what resolution
you're going to be running at post-install in the installer and can't sanely
probe monitors because X is crap ;-)
Comment 3 Ray Strode [halfline] 2005-12-08 14:07:15 EST
Hi,

By "image in the default install" I meant "default background image" :-).  I
didn't mean doing anything at install time.
Comment 4 Ray Strode [halfline] 2006-01-11 14:54:36 EST
Diana, can you send me the individual layers from the default background that we
ship now?  I'm going to try to play with svg and see if i can make an adaptive
background.
Comment 5 Ray Strode [halfline] 2006-01-27 16:07:14 EST
Diana sent me the files, i'll try to look into it soon.
Comment 6 Matthias Clasen 2006-02-01 23:17:32 EST
Ray, I investigated the necessary svg today.

I'll attach my testimage. Here are the relevant points:

1) Set width and height on the svg element to establish the user coordinate system

2) Add the scalable background image with 
       x="0" y="0"
       width="100%" height="100%"
       preserveAspectRatio="none"

This means: fill the full size of the svg with the image

3) Add the decorations (ie the text, bubbles and smoke on transparent
background) with
       x="0" y="0"
       width="100%" height="100%"
       preserveAspectRatio="xMaxYMid meet"

This means: scale the image to fill the full size of the svg, but
only make it as large as you can while keeping the aspect ratio, and
keep all of the image within the viewport. Position the image as far
to the left as possible, and center it vertically.
Comment 7 Matthias Clasen 2006-02-01 23:19:26 EST
Created attachment 124024 [details]
testimage.svg
Comment 8 Matthias Clasen 2006-02-01 23:21:27 EST
Created attachment 124025 [details]
image1.png
Comment 9 Matthias Clasen 2006-02-01 23:22:14 EST
Created attachment 124026 [details]
image2.png
Comment 10 Matthias Clasen 2006-02-02 13:48:11 EST
Ok, scratch this, it doesn't actually work.
SVG seems to not be the right tool for this job
Comment 11 Matthias Clasen 2006-02-04 23:47:02 EST
*** Bug 177176 has been marked as a duplicate of this bug. ***
Comment 12 Matthias Clasen 2006-07-06 17:58:13 EDT
Add to FC6Destop tracker
Comment 13 Alexander Larsson 2006-07-26 15:00:25 EDT
Doing this smart seems hard, I'm just adding a new wide background. Duping to
other bug.

*** This bug has been marked as a duplicate of 176371 ***

Note You need to log in before you can comment on or make changes to this bug.