Bug 177176 - Background artwork needs to take into account wide-aspect screens
Background artwork needs to take into account wide-aspect screens
Status: CLOSED DUPLICATE of bug 175303
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
Depends On:
  Show dependency treegraph
Reported: 2006-01-06 18:35 EST by Rodd Clarkson
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-04 23:46:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2006-01-06 18:35:07 EST
Description of problem:

With the growing number of wide-aspect screens on the market, desktop
backgrounds (especially the default one) need to take into account these screen

While using the 'fill-screen' option works to some degree, it leaves artwork
(especially text and logos - often present on the default background) mis-shaped.

What is needed is a two fold approach.

Firstly, background artwork needs to be supplied in a wide aspect format.  For
example, 1920 x 1200, instead of 1600 x 1200.  This would fill all but the
largests screen (and maybe it needs to be bigger again).

In conjunction with this, the background dialog needs an option to 'scale, but
fill screen'.  The current scale option sees the image scaled, but only to the
narrower of the two sizes, so for example a 1600x1200 images on a 1920x1200
screen would have space on either side, but a 1920x1200 image on a 1600x1200
screen would see the background with space above and below.  This new option
would see a 1920x1200 image on a 1600x1200 screen scaled, but with the sides
chopped off.  By doing this, you could extend current artwork to fit wide-aspect
screens, but so that they also work on standard 4x3 format screens too.
Version-Release number of selected component (if applicable):
Comment 1 Matthias Clasen 2006-02-04 23:46:54 EST

*** This bug has been marked as a duplicate of 175303 ***

Note You need to log in before you can comment on or make changes to this bug.