Bug 175335 - repoquery, yumdownloader broken by yum 2.5.0 update
repoquery, yumdownloader broken by yum 2.5.0 update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 179370 (view as bug list)
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2005-12-08 17:51 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
10 users (show)

See Also:
Fixed In Version: 0.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-25 04:07:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick and dirty fix for repoquery (580 bytes, patch)
2005-12-14 17:07 EST, Ville Skyttä
no flags Details | Diff
Fix yumdownloader for yum 2.5.0 (2.35 KB, patch)
2005-12-15 17:30 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-12-08 17:51:59 EST
The update to yum-2.5.0-0.20051207 in devel seems to have broken repoquery, even
with latest CVS of it.

$ repoquery --whatrequires --alldeps openct
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 646, in ?
    main(sys.argv)
  File "/usr/bin/repoquery", line 598, in main
    repoq = YumBaseQuery(pkgops, sackops, opts)
  File "/usr/bin/repoquery", line 299, in __init__
    self.conf = yum.config.yumconf()
AttributeError: 'module' object has no attribute 'yumconf'
Comment 1 Ville Skyttä 2005-12-09 17:49:29 EST
yumdownloader is broken too (also both in yum-utils-0.3.1-1.fc5 and CVS HEAD):

$ yumdownloader xemacs-sumo
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 27, in ?
    from yum.packages import parsePackages, returnBestPackages
ImportError: cannot import name returnBestPackages
Comment 2 Ville Skyttä 2005-12-14 17:07:41 EST
Created attachment 122252 [details]
Quick and dirty fix for repoquery

Here's a quick and dirty fix for repoquery which appears to work with both yum
2.4.1 and 2.5.0.
Comment 3 Panu Matilainen 2005-12-15 02:12:39 EST
Thanks Ville, applied in yum-utils HEAD.
Comment 4 Ville Skyttä 2005-12-15 15:32:57 EST
Hm, I don't see it applied yet:
http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum-utils/repoquery.py
Comment 6 Ville Skyttä 2005-12-15 16:36:52 EST
No I'm not... it just isn't applied there.
Comment 7 Ville Skyttä 2005-12-15 17:30:15 EST
Created attachment 122306 [details]
Fix yumdownloader for yum 2.5.0

Here's a fix for yumdownloader.  Appears to work only with yum 2.5.0.
Comment 8 Panu Matilainen 2005-12-17 08:49:07 EST
It's applied, seems to be some sort of problem with viewcvs:

[gotcha]$ cvs diff -r 1.25 -r 1.26 repoquery.py
Index: repoquery.py
===================================================================
RCS file: //home/groups/yum/cvs/yum-utils/repoquery.py,v
retrieving revision 1.25
retrieving revision 1.26
diff -u -r1.25 -r1.26
--- repoquery.py        25 Nov 2005 17:33:27 -0000      1.25
+++ repoquery.py        15 Dec 2005 07:14:35 -0000      1.26
@@ -296,7 +296,6 @@
 class YumBaseQuery(yum.YumBase):
     def __init__(self, pkgops = [], sackops = [], options = None):
         yum.YumBase.__init__(self)
-        self.conf = yum.config.yumconf()
         self.options = options
         self.pkgops = pkgops
         self.sackops = sackops
Comment 9 Ville Skyttä 2005-12-17 11:58:03 EST
Okay, you're using a different CVS root than what's instructed at
http://linux.duke.edu/projects/yum/cvs.ptml (/home/groups/yum/cvs vs
/cvsroot/yum/cvs).  I'm using the latter and I guess viewcvs is too.  cvs tells
me that the latest revision in /cvsroot/yum/cvs is 1.25.
Comment 10 Seth Vidal 2005-12-17 12:29:58 EST
viewcvs runs off of an rsync of the cvs tree that's made every half hour.

it doesn't use the live cvs tree.

Comment 11 Tim Mayberry 2006-02-01 01:09:55 EST
It seems that this bug is still apparent in current version of repoquery in the
yum-utils package. If this bug has been fixed is there any plan to release a new
version of the yum-utils package?
Comment 12 Panu Matilainen 2006-02-01 04:32:24 EST
I've been intending to do a new yum-utils release for a while now, yumdownloader
being the thing that's holding it up. The thing is, everything else but it
currently works with both yum-2.4 and 2.5 and I'd hate to fork the development
just because of that... However it seems that there's going to be some major
changes in YUM API in near future which will require forking anyway so maybe
I'll just bite the bullet and make separate releases for 2.4 and 2.5. 
Comment 13 Jeremy Katz 2006-02-09 10:58:27 EST
*** Bug 179370 has been marked as a duplicate of this bug. ***
Comment 14 Hans de Goede 2006-02-17 04:36:30 EST
This is one anoying bug, Seth is it ok with you if I push a nem yum-utils with
these 2 patches to CVS and the build-server (devel branch only)?
Comment 15 Ville Skyttä 2006-02-25 04:07:53 EST
0.5-1 appears to fix these.  yumdownloader is somewhat noisy though:

/usr/lib/python2.4/site-packages/yum/config.py:447: DeprecationWarning:
setConfigOption() will go away in a future version of Yum.
Please set option values as attributes or using setattr().
  DeprecationWarning)
/usr/lib/python2.4/site-packages/yum/config.py:439: DeprecationWarning:
getConfigOption() will go away in a future version of Yum.
Please access option values as attributes or using getattr().
  DeprecationWarning)

Note You need to log in before you can comment on or make changes to this bug.