Bug 175597 - Trailing ellipsis characters in evolution menu names
Trailing ellipsis characters in evolution menu names
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: Yellowpad
  Show dependency treegraph
 
Reported: 2005-12-13 00:54 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 14:25:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 323951 None None None Never

  None (edit)
Description Dave Malcolm 2005-12-13 00:54:46 EST
From the GNOME HIG:
"Command items are menu items that initiate a command or perform an action, such
as Save, Print or Quit. They may act on the currently active document in a
document based application, or on the application itself." ... "Label the menu
item with a trailing ellipsis ("...") only if the command requires further input
from the user before it can be performed. Do not add an ellipsis to items that
only present a confirmation dialog (such as Delete), or that do not require
further input (such as Properties, Preferences or About)." (see
http://developer.gnome.org/projects/gup/hig/2.0/menus-design.html#menu-grouping 


Menu items I think should have trailing ellipsis characters:
Message ->
	Compose New Message
	Post New Message to Folder
	Reply
	Post a Reply
	Reply to Sender
	Reply to List
	Forward
	Redirect
	Move to Folder
	Copy to Folder
	Mailing List ->
			Get list usage information
			Subscribe to list
			Un-subscribe to list
			Post message to list
			Contact list owner
			Get list archive

Version-Release number of selected component (if applicable):
evolution-2.5.2-1
Comment 1 Dave Malcolm 2005-12-13 01:47:59 EST
Posted upstream with proposed patch here:
http://bugzilla.gnome.org/show_bug.cgi?id=323951
Comment 2 Dave Malcolm 2005-12-13 14:49:53 EST
Fix committed to upstream CVS, should make it into 2.5.3 tarball
Comment 4 Matthew Barnes 2006-06-29 22:08:05 EDT
(In reply to comment #2)
> Fix committed to upstream CVS, should make it into 2.5.3 tarball

Dave, did this fix get reverted upstream?  I'm running 2.7.3 and it looks like
nothing has changed.

I got bug #175596 (capitalization) into Rawhide and am pushing for it upstream.
 How strongly do you feel about this one, given upstream's response?
Comment 5 Matthew Barnes 2006-07-13 14:25:07 EDT
It looks like upstream has rejected the changes to the Mailing List submenu and
reverted the changes to the other items in the Message menu, although the
upstream bug report does not reflect this.

I'm going to close this as WONTFIX, since I'm not sure I agree with the proposed
changes either.

Note You need to log in before you can comment on or make changes to this bug.