Bug 175615 - Default NUT Daemon Is Not Configured Correctly
Summary: Default NUT Daemon Is Not Configured Correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 175901 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-13 13:33 UTC by Chris Spencer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 14:27:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Spencer 2005-12-13 13:33:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
After I installing the nut package (Network UPS Tools), and configure it to my particular UPS (a Powercom knockoff) I noticed that upsd isn't properly managed by system-config-services. Specifically, checking it to start at boot time won't actually start the daemon at boot time. Also, clicking "Start" or "Restart" doesn't start the deamon.

In order to get NUT running, after every reboot, I have to manually type:
upsdrvctl start
upsd

Afterwards, system-config-services correctly shows that upsd is running and is able to stop the daemon if I click "Stop", but again is unable to restart the service.

Other that that, NUT functions perfectly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install NUT and configure for a UPS.
2.Reboot machine.
3.Check system-config-services and notice upsd is not running.

Actual Results:  upsd does not start at boot time

Expected Results:  upsd should start at boot time

Additional info:

Comment 1 Ngo Than 2006-03-06 13:39:20 UTC
*** Bug 175901 has been marked as a duplicate of this bug. ***

Comment 2 Ngo Than 2006-03-06 14:27:20 UTC
MODEL=NONE is the default setting.It should work, if you change it to 
MODEL=upsdrvctl. You find the config file in /etc/sysconfig/ups. 
 
I will build new nut package into FC4 update this week, which should fix 
this problem. Thanks for your report. 
 
 


Note You need to log in before you can comment on or make changes to this bug.