Bug 1756257 - podman build fails - create '/sys/fs/cgroup/buildah-buildah523713081': Permission denied
Summary: podman build fails - create '/sys/fs/cgroup/buildah-buildah523713081': Permis...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: podman
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-27 08:35 UTC by Nerijus Baliūnas
Modified: 2019-10-16 13:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 13:14:26 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1732114 0 unspecified CLOSED Modify Fedora 31 to use CgroupsV2 by default 2021-02-22 00:41:40 UTC

Description Nerijus Baliūnas 2019-09-27 08:35:28 UTC
$ podman build -t test .
STEP 1: FROM centos:7
Getting image source signatures
Copying blob d8d02d457314 done
Copying config 67fa590cfc done
Writing manifest to image destination
Storing signatures
STEP 2: RUN yum -y install wget iproute
2019-09-27T08:31:13.000300054Z: create '/sys/fs/cgroup/buildah-buildah523713081': Permission denied
error running container: error creating container for [/bin/sh -c yum -y install wget iproute]: : exit status 1
Error: error building at STEP "RUN yum -y install wget iproute": error while running runtime: exit status 1

The start of Dockerfile is:

FROM centos:7
RUN yum -y install wget iproute

Comment 1 Martin Nowak 2019-09-27 13:58:19 UTC
I think this is caused by bug 1732114
https://fedoraproject.org/wiki/Changes/CGroupsV2#Upgrade.2Fcompatibility_impact mentions a boot option to stick with CGroupsV1 for now, which is a workaround for this bug.

Comment 2 Adam Williamson 2019-10-16 01:10:55 UTC
Reporter, can you test with current packages and see if this is still a problem? There was quite a lot of work around podman/runc/cgroups in the last couple weeks which may have resolved this. Thanks.

Comment 3 Nerijus Baliūnas 2019-10-16 13:14:26 UTC
It works now.


Note You need to log in before you can comment on or make changes to this bug.