Bug 1732114 - Modify Fedora 31 to use CgroupsV2 by default
Summary: Modify Fedora 31 to use CgroupsV2 by default
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
: 1732112 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 17:54 UTC by Ben Cotton
Modified: 2019-10-29 17:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-29 17:13:35 UTC


Attachments (Terms of Use)

Description Ben Cotton 2019-07-22 17:54:29 UTC
This is a tracking bug for Change: Modify Fedora 31 to use CgroupsV2 by default
For more details, see: https://fedoraproject.org/wiki/Changes/CGroupsV2

The kernel has had some support for CgroupsV2 for some time, and yet no one has used it because it is not on by default.  There are lots of new features and fixes over CgroupsV1 that it is time to reveal to the user community.

Comment 1 Daniel Walsh 2019-08-01 23:53:11 UTC
Isn't the only thing that needs to be changed here is systemd to set the default?

Comment 2 Ben Cotton 2019-08-13 18:36:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 Ben Cotton 2019-08-14 17:56:09 UTC
We have reached the 'Code Complete (testable)' milestone in the Fedora 31 release cycle. If your Change is in a testable state, please set the status to MODIFIED. If this Change will not be ready for Fedora 31, please set the version to rawhide.

The 100% code complete deadline is Tue 2019-08-27.

Comment 4 Ben Cotton 2019-08-15 18:39:15 UTC
*** Bug 1732112 has been marked as a duplicate of this bug. ***

Comment 5 Ben Cotton 2019-08-27 17:17:52 UTC
We have reached the '100% Code Complete' milestone in the Fedora 31 release cycle. If your Change is complete, please set the status to ON_QA. The Beta Freeze is underway. If you need a freeze exception, see https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

If this Change will not be ready for Fedora 31, please set the version to rawhide.

Comment 6 Martin Nowak 2019-09-27 13:56:25 UTC
I think this change is responsible for the unprivileged podman build breakage (bug 1756257).

Comment 7 Daniel Walsh 2019-09-27 14:05:35 UTC
You are currect, it is.  Should be fixed in podman 1.6 release.

Comment 8 Ben Cotton 2019-10-29 17:13:35 UTC
Closing Change tracking bugs for the Fedora 31 release.


Note You need to log in before you can comment on or make changes to this bug.