Bug 1756319 - Resources Tab under Custom Resource details page for installed operator crashes
Summary: Resources Tab under Custom Resource details page for installed operator crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1761879
TreeView+ depends on / blocked
 
Reported: 2019-09-27 11:35 UTC by umanga
Modified: 2020-05-13 21:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixes an issue where the web console could experience a runtime error when visiting the Resources tab of an OLM operand resource. Fixes an issue where the web console would freeze when trying to sort the Resources tab for an OLM operand resource.
Clone Of:
: 1761879 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:25:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Resource Listing page (79.13 KB, image/png)
2019-09-27 11:35 UTC, umanga
no flags Details
Crashed Resource Listing Page (144.96 KB, image/png)
2019-09-27 11:37 UTC, umanga
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2979 'None' 'closed' 'Bug 1756319: Fix crash with operand resources' 2019-11-13 00:31:17 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-05-13 21:25:41 UTC

Description umanga 2019-09-27 11:35:14 UTC
Created attachment 1620025 [details]
Resource Listing page

Description of problem:
When I follow Installed Operators > Custom Resource > Resources Tab, I see resources managed by my operator. 

I can follow the link to details page of respective resource.

After that, when I press Back button to go one page back to Resources tab, the page crashes.


Version-Release number of selected component (if applicable):
4.2.0-0.ci-2019-09-26-140811

How reproducible:
100%

Steps to Reproduce:
1. Install operator that manages some resources
2. Go to resource details page of any resource managed by that operator
3. Press back button on the browser to go back to resource listing page
4. The page will crash.

Actual results:
Page crashes with an error dump.

Expected results:
Page should list the Resources managed by the operator or at least not crash.

Additional info:

TypeError
```
Description:

e.data is undefined

Component Trace

in ListPageWrapper_
    in Unknown
    in Unknown
    in C
    in t
    in C
    in div
    in t
    in C
    in C
    in MultiListPage
    in Resources
    in component
    in t
    in t
    in div
    in Data
    in StatusBox
    in div
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown
    in C
    in t
    in C
    in Unknown
    in t
    in DetailsPage
    in OperandDetailsPage
    in t
    in Unknown
    in C
    in t
    in t
    in div
    in div
    in section
    in d
    in Unknown
    in withRouter(undefined)
    in C
    in main
    in div
    in y
    in t
    in t
    in t
    in t

Stack trace

g/<.flatten</<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/main-chunk-cd0828353b6862fd2e72.min.js:1:248526
t.a/<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:39:52489
t.a/<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:56:30022
t.a@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:22:50394
t.a/<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:56:32087
t.a@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:39:52463
t.a@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:12:11209
t.a@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:22:20990
g/<.flatten<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/main-chunk-cd0828353b6862fd2e72.min.js:1:248508
1323/R</t.prototype.render@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/main-chunk-cd0828353b6862fd2e72.min.js:1:114950
ki@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:63012
Ti@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:62807
Mi@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:66641
Va@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:90685
qa@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:91069
ku@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:97956
Au@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:97336
Pu@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:104:98430
notify@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:22:26329
a</t.notifyNestedSubs@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:22:25899
f</n.notifySubscribers@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:44:176151
a</t.handleChangeWrapper@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:22:25967
v@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:22:29187
d/</</<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/main-chunk-cd0828353b6862fd2e72.min.js:1:200253
dispatch@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:22:32686
l/<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/main-chunk-cd0828353b6862fd2e72.min.js:1:5837
a@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:88:32986
j/<@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:88:33108
l@https://console-openshift-console.apps.uchapaga-sep27.devcluster.openshift.com/static/vendors~main-chunk-251a4415a6dc7d238b92.min.js:88:35744
```

Comment 1 umanga 2019-09-27 11:37:04 UTC
Created attachment 1620027 [details]
Crashed Resource Listing Page

Comment 2 Samuel Padgett 2019-09-27 15:41:38 UTC
I can't reproduce. Is this an issue for all operators or only OCS? Can you provide more precise steps to reproduce with the exact operator you're using?

Comment 3 Samuel Padgett 2019-09-27 15:43:53 UTC
My suspicion is that the error is here, but I can't confirm without being able to reproduce:

https://github.com/spadgett/console/blob/300721c135504f9976954070402709ff9b047299/frontend/packages/operator-lifecycle-manager/src/components/operand.tsx#L268

Comment 7 Yadan Pei 2019-10-25 06:09:09 UTC
Tried to install some operators on 4.3.0-0.nightly-2019-10-24-203507 and didn't meet this issue.

Going to verify it, will reopen if it appears again

Comment 9 errata-xmlrpc 2020-05-13 21:25:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.