Bug 1761879 - Resources Tab under Custom Resource details page for installed operator crashes
Summary: Resources Tab under Custom Resource details page for installed operator crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.2.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1766750 (view as bug list)
Depends On: 1756319
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-15 13:46 UTC by Samuel Padgett
Modified: 2019-11-13 18:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixes an issue where the web console could experience a runtime error when visiting the Resources tab of an OLM operand resource. Fixes an issue where the web console would freeze when trying to sort the Resources tab for an OLM operand resource.
Clone Of: 1756319
Environment:
Last Closed: 2019-11-13 18:55:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2981 0 'None' closed Bug 1761879: Fix crash with operand resources 2020-03-18 23:51:34 UTC
Red Hat Product Errata RHBA-2019:3303 0 None None None 2019-11-13 18:56:02 UTC

Internal Links: 1766750

Comment 1 Samuel Padgett 2019-10-30 14:13:53 UTC
*** Bug 1766750 has been marked as a duplicate of this bug. ***

Comment 3 Yanping Zhang 2019-11-05 06:29:31 UTC
Tested on OCP 4.2 with payload:4.2.0-0.nightly-2019-11-01-115323
Installed a operator in project, subscribed, then check "Resources" tab, click into on resource, than click back to "Resources" tab, the page didn't crash.

Comment 5 errata-xmlrpc 2019-11-13 18:55:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3303


Note You need to log in before you can comment on or make changes to this bug.