Bug 1756521 - urw-base35-fonts-20170801-10.el7.noarch.rpm removes fonts in /usr/share/fonts/default/Type1 and breaks htmldoc symlinks in /usr/share/htmldoc/fonts
Summary: urw-base35-fonts-20170801-10.el7.noarch.rpm removes fonts in /usr/share/fonts...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: htmldoc
Version: epel7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-27 20:16 UTC by Tony Poisson
Modified: 2019-11-09 21:17 UTC (History)
5 users (show)

Fixed In Version: htmldoc-1.8.28-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-09 21:17:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Tony Poisson 2019-09-27 20:16:59 UTC
Description of problem:yum update applying urw-base35-fonts-20170801-10.el7.noarch.rpm removes fonts in /usr/share/fonts/default/Type1 and breaks htmldoc symlinks in /usr/share/htmldoc/fonts


Version-Release number of selected component (if applicable):htmldoc-1.8.28-4.el7.x86_64.rpm 


How reproducible:yum update on a RHEL 7.7 without excluding URW fonts


Steps to Reproduce:
1.yum update will update the URW 35 fonts and separate into a different /usr/share/fonts path and empty the /usr/share/fonts/default/Type1/ folder
2.this will break the symlinks in the /usr/share/htmldoc/fonts/ folder and affect the operation of htmldoc
3.PDFs created through htmldoc will subsequently be created incorrectly due to the inability to link to the correct font files.

Actual results:Incorrect display and production of PDF files through htmldoc


Expected results:


Additional info: RHEL support suggested that we install the urw-base35-fonts-legacy from the optional channel and recreate the symlinks affected to the new location of the legacy fonts. I did so and created a script to recreate the symlinks to point to the new legacy fonts path of /usr/share/X11/urw-fonts/. It would make more sense to rebuild the htmldoc package with the fonts in the package rather than utilizing symlinks.

Comment 1 Fedora Update System 2019-10-21 21:53:29 UTC
FEDORA-EPEL-2019-5ea9f8e941 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5ea9f8e941

Comment 2 Tru Huynh 2019-10-22 18:50:48 UTC
I think that issue is also raised with grace (https://bugzilla.redhat.com/show_bug.cgi?id=1751353) and ImageMagick (https://bugs.centos.org/view.php?id=16443)

Comment 3 Rex Dieter 2019-10-22 18:58:11 UTC
Yep, similar issue

Comment 4 Tony Poisson 2019-10-22 19:08:50 UTC
So, I am not familiar with the normal procedure for these kind of issues, Can the package be redone to include the fonts internally rather than utilizing symlinks or possibly redoing the symlinks to point to the new location where the legacy URW-35 package now puts the fonts?

Comment 5 Rex Dieter 2019-10-22 21:32:02 UTC
The update I submitted,
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5ea9f8e941

used the strategy of updating the symlinks to point to the urw-35 legacy fonts.

(Newer htmldoc packaging in fedora currently uses it's own internal/bundled fonts, but that's primarily out of necessity, because the patch to use system fonts was never ported or upstreamed)

Comment 6 Fedora Update System 2019-10-25 19:45:38 UTC
htmldoc-1.8.28-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5ea9f8e941

Comment 7 Fedora Update System 2019-11-09 21:17:27 UTC
htmldoc-1.8.28-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.