Bug 175672 - MIDI playback is broken on x86_64
Summary: MIDI playback is broken on x86_64
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL_mixer   
(Show other bugs)
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 188952
TreeView+ depends on / blocked
 
Reported: 2005-12-13 20:48 UTC by Göran Uddeborg
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-23 16:04:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x86_64 typedef fix (426 bytes, patch)
2006-04-21 02:54 UTC, Wart
no flags Details | Diff

Description Göran Uddeborg 2005-12-13 20:48:37 UTC
Description of problem:
Playing a MIDI file with SDL_mixer sounds awful.

Version-Release number of selected component (if applicable):
SDL_mixer-1.2.6-3.fc4.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Find a MIDI file.  (E.g., install nethack-vultures. :-)
2.playmus /usr/games/vultureseye/music/nethack.mid
  
Actual results:
Very distorted sound

Additional info:
This happens only with the x86_64 build.  Installing the same version of
SDL_mixer (and its dependencies) from the i386 build of FE sounds fine!

Timidity, x86_64 build, also sounds fine.

Comment 1 Wart 2006-04-20 22:27:37 UTC
This one has bitten me in prboom as well.  It's also a problem on FC-5 in
version SDL_mixer-1.2.6-6.fc5.x86_64.

Comment 2 Brian Pepple 2006-04-20 23:33:09 UTC
I'm not sure how I'm going to be able to fix this one, since I don't have an
x86_64 machine to reproduce this.  So, most likely a fix will need to come from
upstream.

Comment 3 Wart 2006-04-21 00:05:04 UTC
I filed a bug report upstream:
https://bugzilla.libsdl.org/show_bug.cgi?id=202

Comment 4 Wart 2006-04-21 02:54:57 UTC
Created attachment 128072 [details]
x86_64 typedef fix

I found a simple fix.  There is a bad 32-64 bit typedef in one of the timidity
wrapper header files.  I haven't tested this on i386, but it definitely fixes
the problem on x86_64.

Comment 5 Brian Pepple 2006-04-23 16:04:00 UTC
Thanks for the patch.  I tested it on my i386 machines the last couple of day
and didn't have any problems.  New packages should be available with the next
signing/push.


Note You need to log in before you can comment on or make changes to this bug.