Bug 188952 - Enabling Music Causes Sound Anomolies
Enabling Music Causes Sound Anomolies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: prboom (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On: 175672
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 17:25 EDT by Christopher Stone
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-23 14:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2006-04-13 17:25:03 EDT
Description of problem:  When music is enabled it is choppy and distorted.


Version-Release number of selected component (if applicable):
freedoom-0.4.1-3.fc5

How reproducible:
Turn music volume on and restart freedoom

Additional info:
Multimedia audio controller: Creative Labs SB Audigy (rev 04)
Comment 1 Wart 2006-04-18 21:28:01 EDT
I can't seem to get the music to play anything useful either.  version 2.4.1 was
released about a week ago.  They don't advertise fixes to the sound system, but
I'll see if it helps nonetheless.
Comment 2 Wart 2006-04-19 11:42:17 EDT
The problem still exists in 2.4.1.  Nevertheless, I'll still upgrade the package
to this latest release.
Comment 3 Wart 2006-04-19 16:27:29 EDT
Changing the component from freedoom to prboom as it's a problem with the game
engine, not the game data files.
Comment 4 Wart 2006-04-20 02:28:51 EDT
Are you running this on x86_64 or i386?  I just tried on FC-5 i386 in vmware and
the music played fine.  But on my FC-4 x86_64 box it's comes out as static.  The
results were the same for prboom 2.3.1 and 2.4.1.

I'm bringing up FC4-i386 for testing now and will try FC-5 x86_64 tomorrow.
Comment 5 Christopher Stone 2006-04-20 08:03:15 EDT
x86_64. 
Comment 6 Hans de Goede 2006-04-20 09:43:33 EDT
Looks most definetly like an x86_64 problem them, I'll see if I can reproduce it
on my x86_64 too. Ofso I can try to take a look, but currently my time is
limited and there are other higher priority fedora related things on my todo.
Comment 7 Wart 2006-04-20 13:08:35 EDT
Further testing shows that it only happens on x86_64.  The music plays fine on
FC4 and FC5 i386.

Here's some info that might help with debugging:

The music files are stored in the freedoom iwad /usr/share/doom/freedoom.wad. 
You can extract them with deutex:
# cp /usr/share/doom/freedoom.wad ./doom2.wad
# deutex -xtract ./doom2.wad
(I've got a patch to simplify this, but the buildsys is down right now)

The music files will be extracted into ./musics.  They are midi files in .mus
format.  I haven't had a chance to track down the midi playing code in prboom
yet, and I've had trouble getting a midi player to play them at all.  I suspect
they're in some special format that gets processed inside of prboom.
Comment 8 Wart 2006-04-20 18:23:05 EDT
More debugging info:

prboom converts the music resources in the iwad into a temp midi file in /tmp. 
I verified that the converted files are identical on x86_64 and i386.

You can play the converted file manually by using the SDL_mixer program 'playmus'.

However, on x86_64, playmus does not play the file correctly.  It does play it
correctly on i386.  This sounds to me like a SDL_mixer problem.

Here is one of the converted midi files from prboom that you can test with:
http://www.kobold.org/~wart/fedora/prboom.mid
Comment 9 Wart 2006-04-20 18:26:51 EDT
This looks like the same problem reported here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=175672
Comment 10 Wart 2006-04-23 14:35:27 EDT
A new SDL_mixer build has been pushed that should fix this issue.  Setting
resolution to 'NOTABUG' since this is not a bug in prboom.

Note You need to log in before you can comment on or make changes to this bug.