Bug 1757501 - when redeploying logging using no_proxy and generate_no_proxy_hosts = true, kibana proxy container does not include the master nodes in no_proxy env variable
Summary: when redeploying logging using no_proxy and generate_no_proxy_hosts = true, k...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.11.z
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
: 1767238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-01 17:18 UTC by German Parente
Modified: 2019-11-18 14:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 14:52:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-ansible pull 11971 0 'None' closed Bug 1757501: Fixup kibana-proxy proxy variable sources 2020-12-14 04:52:36 UTC
Red Hat Knowledge Base (Solution) 4494041 0 None None None 2019-11-18 10:54:03 UTC
Red Hat Product Errata RHBA-2019:3817 0 None None None 2019-11-18 14:52:21 UTC

Description German Parente 2019-10-01 17:18:29 UTC
Description of problem:

Version-Release number of the following components:

rpm -q openshift-ansible
3.11.141

How reproducible:

customer is using a proxy. And setting no_proxy variable and generate_no_proxy_hosts=true in inventory.

the master ip is not set in the kibana-proxy container enviroment variable no_hosts.

I will provide an example of this.

Comment 3 Scott Dodson 2019-10-22 12:59:11 UTC
Please see https://github.com/openshift/openshift-ansible/pull/11971 for the proposed fix.
In the mean time this can be worked around by adding the kubernetes service IP, which is always the first IP in the openshift_portal_net range, to openshift_no_proxy value. The IP address that kibana-proxy is using is NOT a host IP.

Comment 4 Scott Dodson 2019-10-31 22:38:34 UTC
*** Bug 1767238 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2019-11-18 14:52:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3817


Note You need to log in before you can comment on or make changes to this bug.