Bug 175757 - rc.sysinit doesn't load proper module for lvm snapshots
rc.sysinit doesn't load proper module for lvm snapshots
Status: CLOSED DUPLICATE of bug 170339
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2005-12-14 12:06 EST by Scott Zahn
Modified: 2014-03-16 22:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-14 12:37:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
the patch to the problem (2.79 KB, patch)
2005-12-14 12:16 EST, Scott Zahn
no flags Details | Diff

  None (edit)
Description Scott Zahn 2005-12-14 12:06:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050802 Firefox/1.0.6

Description of problem:
rc.sysinit doesn't load the dm_snapshot module when lvm snapshots are present. The result is that LVM volumes with snapshots fail to init.  Even though the version of rpm I'm reporting is from CentOS, I'm fairly certain given the similarity between the two distros that this bug is present in RHEL 4.2 as well.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. make an lvm volume and mount it.  add entry in fstab.
2. make a snapshot for lvm volume.
3. reboot.  the lvm volume won't init.

Actual Results:  because the dm_snapshots module isn't loaded, the lvm volume will fail to init.

Expected Results:  the dm_snapshots module should have loaded to facilitate the init of the lvm volume which the snapshots are a part of.

Additional info:

Needless to say, this is a very bad thing to have happen if the lvm volume in question contains important stuff.  Since there's no field in this form to submit unified diffs, here's the url where my fix to this problem can be found:


Let me know how well this works for you guys. Thanks.
Comment 1 Bill Nottingham 2005-12-14 12:09:25 EST
(There is a 'create attachment', btw.)

There really should be some way to automatically load this when needed. Why
shouldn't the lvm/multipath/etc tools do this, if they see a map of the
appropriate type configured?
Comment 2 Scott Zahn 2005-12-14 12:16:42 EST
Created attachment 122232 [details]
the patch to the problem
Comment 3 Alasdair Kergon 2005-12-14 12:21:00 EST
As of RHEL4 U3, lvm2 should attempt to load the modules if necessary.  See bug
Comment 4 Scott Zahn 2005-12-14 12:31:30 EST
I checked out but 170339, but didn't see much info in there.  It doesn't seem to
have anything to do with supporting snapshots.  Does the fix for that bug also
fix this one?
Comment 5 Alasdair Kergon 2005-12-14 12:36:38 EST
Yes it should do - all targets use the same function which does the
Comment 6 Bill Nottingham 2005-12-14 12:37:37 EST
OK, closing this.

*** This bug has been marked as a duplicate of 170339 ***

Note You need to log in before you can comment on or make changes to this bug.