Bug 1758731 - SELinux is preventing boltd from 'read' accesses on the lnk_file 05901221-D566-11D1-B2F0-00A0C9062910.
Summary: SELinux is preventing boltd from 'read' accesses on the lnk_file 05901221-D56...
Keywords:
Status: CLOSED DUPLICATE of bug 1759019
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b66c51ff9104d836a4c679eb71e...
: 1758732 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-05 05:58 UTC by Mikhail
Modified: 2019-10-07 11:17 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.14.5-6.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-07 11:17:46 UTC
Type: ---


Attachments (Terms of Use)

Description Mikhail 2019-10-05 05:58:23 UTC
Description of problem:
SELinux is preventing boltd from 'read' accesses on the lnk_file 05901221-D566-11D1-B2F0-00A0C9062910.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that boltd should be allowed read access on the 05901221-D566-11D1-B2F0-00A0C9062910 lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'boltd' --raw | audit2allow -M my-boltd
# semodule -X 300 -i my-boltd.pp

Additional Information:
Source Context                system_u:system_r:boltd_t:s0
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                05901221-D566-11D1-B2F0-00A0C9062910 [ lnk_file ]
Source                        boltd
Source Path                   boltd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.5-6.fc32.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 5.4.0-0.rc1.git0.1.fc32.x86_64 #1
                              SMP Wed Oct 2 14:56:16 UTC 2019 x86_64 x86_64
Alert Count                   2
First Seen                    2019-10-05 10:37:00 +05
Last Seen                     2019-10-05 10:57:45 +05
Local ID                      0acb6b6a-ffd1-400e-acd6-c5a88f1d6f31

Raw Audit Messages
type=AVC msg=audit(1570255065.206:227): avc:  denied  { read } for  pid=2966 comm="boltd" name="05901221-D566-11D1-B2F0-00A0C9062910" dev="sysfs" ino=31170 scontext=system_u:system_r:boltd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=lnk_file permissive=1


Hash: boltd,boltd_t,sysfs_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.14.5-6.fc32.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.4.0-0.rc1.git0.1.fc32.x86_64
type:           libreport

Comment 1 Christian Kellner 2019-10-05 18:51:20 UTC
*** Bug 1758732 has been marked as a duplicate of this bug. ***

Comment 2 Christian Kellner 2019-10-05 18:53:31 UTC
I guess practically a duplicate of bug 1754360 but this is filed against rawhide, so I am just closing this (build is here: https://koji.fedoraproject.org/koji/buildinfo?buildID=1396383).

Comment 3 Christian Kellner 2019-10-05 19:10:40 UTC
Sorry, I was too quick, this might have actually caused by the changes that were applied to fix bug 1754360. See https://bugzilla.redhat.com/show_bug.cgi?id=1758746#c3 for details.

Comment 4 Lukas Vrabec 2019-10-07 11:17:46 UTC

*** This bug has been marked as a duplicate of bug 1759019 ***


Note You need to log in before you can comment on or make changes to this bug.