Bug 1759019 - SELinux is preventing boltd from 'getattr' accesses on the lnk_file /sys/bus/wmi/devices/7FF47003-3B6C-4E5E-A227-E979824A85D1.
Summary: SELinux is preventing boltd from 'getattr' accesses on the lnk_file /sys/bus/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 30
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:93c67c027aca812043da493589b...
: 1758731 1758808 1759018 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-07 08:18 UTC by Kamil Páral
Modified: 2019-11-17 01:13 UTC (History)
15 users (show)

Fixed In Version: selinux-policy-3.14.3-52.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-17 01:13:34 UTC


Attachments (Terms of Use)

Description Kamil Páral 2019-10-07 08:18:11 UTC
Description of problem:
I started my laptop (T480s with Thunderbolt) and logged in.
SELinux is preventing boltd from 'getattr' accesses on the lnk_file /sys/bus/wmi/devices/7FF47003-3B6C-4E5E-A227-E979824A85D1.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that boltd should be allowed getattr access on the 7FF47003-3B6C-4E5E-A227-E979824A85D1 lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'boltd' --raw | audit2allow -M my-boltd
# semodule -X 300 -i my-boltd.pp

Additional Information:
Source Context                system_u:system_r:boltd_t:s0
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                /sys/bus/wmi/devices/7FF47003-3B6C-4E5E-A227-E9798
                              24A85D1 [ lnk_file ]
Source                        boltd
Source Path                   boltd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-48.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 5.2.18-200.fc30.x86_64 #1 SMP Tue
                              Oct 1 13:14:07 UTC 2019 x86_64 x86_64
Alert Count                   1
First Seen                    2019-10-07 10:13:58 CEST
Last Seen                     2019-10-07 10:13:58 CEST
Local ID                      1af9ebb0-84d7-4f3e-a33d-4093f0892709

Raw Audit Messages
type=AVC msg=audit(1570436038.341:222): avc:  denied  { getattr } for  pid=2635 comm="boltd" path="/sys/bus/wmi/devices/7FF47003-3B6C-4E5E-A227-E979824A85D1" dev="sysfs" ino=23728 scontext=system_u:system_r:boltd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=lnk_file permissive=1


Hash: boltd,boltd_t,sysfs_t,lnk_file,getattr

Version-Release number of selected component:
selinux-policy-3.14.3-48.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.2.18-200.fc30.x86_64
type:           libreport

Potential duplicate: bug 1758808

Comment 1 Lukas Vrabec 2019-10-07 08:58:08 UTC
*** Bug 1758808 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2019-10-07 09:20:23 UTC
commit f4cc781a4aaa125bd050b76bfb4537509aca6323 (HEAD -> rawhide)
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Oct 7 11:20:02 2019 +0200

    Update dev_manage_sysfs() to support managing also lnk files BZ(1759019)

Comment 3 gilles.abramovici 2019-10-07 11:05:31 UTC
Description of problem:
J'ignore tout sauf que ceci suit une mise à jour


Additional info:
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.2.18-200.fc30.x86_64
type:           libreport

Comment 4 Lukas Vrabec 2019-10-07 11:08:44 UTC
*** Bug 1758746 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Vrabec 2019-10-07 11:17:25 UTC
*** Bug 1759018 has been marked as a duplicate of this bug. ***

Comment 6 Lukas Vrabec 2019-10-07 11:17:46 UTC
*** Bug 1758731 has been marked as a duplicate of this bug. ***

Comment 7 Adam Williamson 2019-10-10 03:17:51 UTC
Description of problem:
Occurred on boot after an update.

Version-Release number of selected component:
selinux-policy-3.14.3-48.fc30.noarch

Additional info:
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.3.5-200.fc30.x86_64
type:           libreport

Comment 8 Fedora Update System 2019-10-10 07:49:07 UTC
FEDORA-2019-6bbf3d600d has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6bbf3d600d

Comment 9 Fedora Update System 2019-10-10 07:49:22 UTC
FEDORA-2019-6bbf3d600d has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6bbf3d600d

Comment 10 Fedora Update System 2019-10-10 17:29:25 UTC
selinux-policy-3.14.3-49.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6bbf3d600d

Comment 11 Fedora Update System 2019-10-23 07:00:46 UTC
FEDORA-2019-d68c9e27f8 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d68c9e27f8

Comment 12 Fedora Update System 2019-10-25 19:34:18 UTC
selinux-policy-3.14.3-50.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d68c9e27f8

Comment 13 Fedora Update System 2019-10-26 17:03:10 UTC
FEDORA-2019-f83217e2bf has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f83217e2bf

Comment 14 Fedora Update System 2019-10-27 03:55:07 UTC
selinux-policy-3.14.3-51.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f83217e2bf

Comment 15 Fedora Update System 2019-11-03 14:11:10 UTC
FEDORA-2019-70d80ad4bc has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-70d80ad4bc

Comment 16 Fedora Update System 2019-11-04 02:10:34 UTC
selinux-policy-3.14.3-52.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-70d80ad4bc

Comment 17 Fedora Update System 2019-11-17 01:13:34 UTC
selinux-policy-3.14.3-52.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.