Bug 175971 - Bad: RTL8100C MAC supported by 8139too, but not communicating with PHY
Bad: RTL8100C MAC supported by 8139too, but not communicating with PHY
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
: 175972 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 14:51 EST by Bryan J. Smith
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 18:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan J. Smith 2005-12-16 14:51:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
RealTek RTL8100C 32-bit PCI (3.3V, 5V tolerant) 4-Port Switch Card (MAC + PHY  + on-PCB/card switch)
Class 0200 PCI device 10ec:8139

"8139too" driver loaded by kudzu, seems to communicate with MAC of the NIC.
Link lights will come on, but no links are established to any connections -- e.g., miitool shows no link status.
Possible unsupported MAC+PHY configuration?

Attempting to use the "8139cp" driver fails to communicate with the card at all.
Again, "8139too" driver loads, even returns MAC address and can be configured (e.g., ifconfig), but no communication is possible.
No cabling or other issues, tried different cards in different RHEL 3 ES Update 6 systems.

Systems using the card are HP DL360 G4 (1U rackmount) in PCI-X (3.3V) slot.
Using another 32-bit PCI (3.3V, 5V tolerant) NIC in the slot works without issue.
So it's not a PCI-X slot issue, it can and is driving another 32-bit PCI (3.3V) card.

Have used RealTek RTL8139D 32-bit PCI (5V-only) 4-port Switch Cards prior with no issues.
Had to switch to the newer RTL8100C designs for 3.3V support (such as when putting in PCI-X systems which use 3.3V).


Version-Release number of selected component (if applicable):
Update 6 (kernel-2.4.21-4.EL)

How reproducible:
Always

Steps to Reproduce:
1.  Use RealTek RTL8100C PCI (3.3V) NIC hardware
2.  Boot RHEL3 (any update, Update 6 used here) where "8139too" driver loads and configures interface
3.  Attempt any communication, link status (miitool), etc...
  

Actual Results:  Absolutely no communication.  Not even "tcpdump -i" sees any communication.  "miitool" reports no links.  Even the lights on the card itself fails to show a link.  Either I have a bad batch of cards, or more likely, the MAC is supported by the "8139too" driver, but there is something with the PHY chips that is not.

Additional info:

Willing to run any additional diagnostics/programs/kernel stubs/etc... to debug issue.  Please advise on next course of action to debug.
Comment 1 Bryan J. Smith 2005-12-16 14:53:06 EST
*** Bug 175972 has been marked as a duplicate of this bug. ***
Comment 2 Ernie Petrides 2005-12-19 18:14:22 EST
*** Bug 175972 has been marked as a duplicate of this bug. ***
Comment 3 Ernie Petrides 2005-12-19 18:17:08 EST
*** Bug 175972 has been marked as a duplicate of this bug. ***
Comment 4 Bryan J. Smith 2006-01-03 10:58:22 EST
Has anyone at Red Hat attempted to duplicate this issue?
Or does anyone have a RTL8100C NIC they are having no issues (or any issues) with?
Comment 5 John W. Linville 2006-01-03 11:04:50 EST
Just back from holidays...I don't have the hardware in question, but I'll look 
around... 
 
Is there any chance you could try this hardware with a RHEL4 or FC4 box? 
Comment 6 Bryan J. Smith 2006-01-03 23:33:21 EST
I can try it with Fedora Core 3 and 4 Rescue CDs to start.
I want to say I already have tried with FC3's Rescue CD to no avail.
But I will verify both tomorrow.
Comment 8 John W. Linville 2006-01-04 13:44:15 EST
Bryan, can you identify the actual product (i.e. something I can 
Google/Froogle to find) for the failing card? 
Comment 9 Bryan J. Smith 2006-01-11 18:53:40 EST
UPDATE:  

Okay, we've run into issues that are starting to suggest it is a hardware
problem.   We're having trouble with the card in Windows as well, with both the
stock 8139 driver as well as an updated 8139D/8100C driver.  So I don't think
this is an issue with the 8139too driver anymore.  We're getting in more cards
to verify.

I'm changing the status to "NOTABUG" and putting it back on me to test further.

IDENTIFICATION: 

These cards are very difficult to nail down specifically.  You'll find them
marketed as a Generical Part Number such as "A-3500" as a "4-port SWITCH/ROUTER
CARD" -- essentially a 4-port switch card, with bundled software NAT.  We like
them because they remove the need for an external switch, and essentially give
us 5 systems (the 1 internally connected, plus the 4-ports).  They can be had
for sub-$25.

The problem is the resellers do NOT differentiate between the old 5V-only
RTL8139D cards and the newer 3.3V (5V tolerant) RTL8100C versions.  We've used
the former without issue with the 8139too driver.  This was our first attempt
with the newer ones, and now that we've confirmed the same PHY issues under
Windows, this doesn't look like an 8139too driver issue.

Note You need to log in before you can comment on or make changes to this bug.