Bug 175972 - Bad: RTL8100C MAC supported by 8139too, but not communicating with PHY
Bad: RTL8100C MAC supported by 8139too, but not communicating with PHY
Status: CLOSED DUPLICATE of bug 175971
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 14:51 EST by Bryan J. Smith
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 18:16:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan J. Smith 2005-12-16 14:51:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
RealTek RTL8100C 32-bit PCI (3.3V, 5V tolerant) 4-Port Switch Card (MAC + PHY  + on-PCB/card switch)
Class 0200 PCI device 10ec:8139

"8139too" driver loaded by kudzu, seems to communicate with MAC of the NIC.
Link lights will come on, but no links are established to any connections -- e.g., miitool shows no link status.
Possible unsupported MAC+PHY configuration?

Attempting to use the "8139cp" driver fails to communicate with the card at all.
Again, "8139too" driver loads, even returns MAC address and can be configured (e.g., ifconfig), but no communication is possible.
No cabling or other issues, tried different cards in different RHEL 3 ES Update 6 systems.

Systems using the card are HP DL360 G4 (1U rackmount) in PCI-X (3.3V) slot.
Using another 32-bit PCI (3.3V, 5V tolerant) NIC in the slot works without issue.
So it's not a PCI-X slot issue, it can and is driving another 32-bit PCI (3.3V) card.

Have used RealTek RTL8139D 32-bit PCI (5V-only) 4-port Switch Cards prior with no issues.
Had to switch to the newer RTL8100C designs for 3.3V support (such as when putting in PCI-X systems which use 3.3V).


Version-Release number of selected component (if applicable):
Update 6 (kernel-2.4.21-4.EL)

How reproducible:
Always

Steps to Reproduce:
1.  Use RealTek RTL8100C PCI (3.3V) NIC hardware
2.  Boot RHEL3 (any update, Update 6 used here) where "8139too" driver loads and configures interface
3.  Attempt any communication, link status (miitool), etc...
  

Actual Results:  Absolutely no communication.  Not even "tcpdump -i" sees any communication.  "miitool" reports no links.  Even the lights on the card itself fails to show a link.  Either I have a bad batch of cards, or more likely, the MAC is supported by the "8139too" driver, but there is something with the PHY chips that is not.

Additional info:

Willing to run any additional diagnostics/programs/kernel stubs/etc... to debug issue.  Please advise on next course of action to debug.
Comment 1 Bryan J. Smith 2005-12-16 14:52:58 EST

*** This bug has been marked as a duplicate of 175971 ***
Comment 2 Ernie Petrides 2005-12-19 18:13:08 EST
Reopening/reclosing to get off of kernel-maint list.
Comment 3 Ernie Petrides 2005-12-19 18:14:13 EST

*** This bug has been marked as a duplicate of 175971 ***
Comment 4 Ernie Petrides 2005-12-19 18:15:43 EST
Let's try that again (in 3 steps, this time).
Comment 5 Ernie Petrides 2005-12-19 18:16:55 EST

*** This bug has been marked as a duplicate of 175971 ***

Note You need to log in before you can comment on or make changes to this bug.