Bug 176002 - Keyboard settings broken since modular X upgrade
Keyboard settings broken since modular X upgrade
Status: CLOSED DUPLICATE of bug 173267
Product: Fedora
Classification: Fedora
Component: libxklavier (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-12-17 00:08 EST by Ralph Loader
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 15:34:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Loader 2005-12-17 00:08:34 EST
Setting keyboard options via gnome-keyboard-properties result in an error dialog
popping up saying:

---------------------------------------------------------------------Error
activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
69999902

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
--------------------------------------------------------------------------

(I also get the same dialog when logging in).

I suspect that the following may be to blame:

$ strings /usr/lib/libxklavier.so.10|grep X11R6
-I/usr/X11R6/lib/X11/xkb
/usr/X11R6/lib/X11/xkb/rules/%s.xml
/usr/X11R6/lib/X11/xkb/rules/%s
/usr/X11R6/lib/X11/xkb/xkbcomp

$ rpm -q libxklavier
libxklavier-2.0-3
Comment 1 Ralph Loader 2005-12-17 02:10:01 EST
Oh yeah, the two things the error message asks me to include:

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model = hpi6
 options = []
 overrideSettings = true
Comment 2 Ralph Loader 2005-12-17 20:53:59 EST
According to the ChangeLog, libxklavier 2.1 fixes a bug with identical symptoms.
 (And it might just be coincidence that it broke when I upgraded to modular X).
Comment 3 Ralph Loader 2006-01-04 23:47:19 EST
Well the libxklavier-2.1 has removed the error dialog, but x keyboard settings
are still broken.

On the gnome-keyboard-properties 'Layout options' tag, I have just

  Miscellaneous compatibility options
     Shift with numpad keys works as in MS Windows
     Special keys (Ctrl+Alt+<key>) handled in server

and no others.
Comment 4 Chris Tyler 2006-01-17 23:26:13 EST
When testing FC5T2 and the "Canadian>French (legacy)" keyboard setting in Gnome
Keyboard Preferences, turning off the "Shift with numpad keys works as in MS
Windows" setting under "Layout Options" seems to let the keyboard work, but
turning it on seems to provoke the problems described above (and more: sometimes
the settings silently don't work, sometimes a dialog keeps flashing up (no text,
dialog disappears immediately, then reappears), sometimes there is a message
saying that the gnome settings daemon died too many times) - perhaps this is due
to a missing/incompatible keyboard variant?

(It looks like the X.org xkb layouts were substantially changed between 6.8.2
and 7.0, layouts such as ca_enhanced are gone).
Comment 5 Matthias Clasen 2006-02-10 00:21:36 EST
We could probably dupe this to bug 173267
Comment 6 Matthias Clasen 2006-02-14 15:34:00 EST

*** This bug has been marked as a duplicate of 173267 ***

Note You need to log in before you can comment on or make changes to this bug.