Bug 173267 - (xorg7-bad-xkbdata) Modular X: keyboard map changes in gnome keyboard applet
Modular X: keyboard map changes in gnome keyboard applet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 176002 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 14:39 EST by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 08:33:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 323210 None None None Never

  None (edit)
Description Nicolas Mailhot 2005-11-15 14:39:38 EST
Modular X uses new xkbdata wich is significantly different from the one in old xorg

In particular with modular X the current keyboard applet is unable to manage
layouts : only the xorg.conf keyboard is diplayed, one can not select any other one

The applet needs to be updated to cope with the new system to be of any use

gnome-applets-2.12.1-3
Comment 1 Nicolas Mailhot 2005-12-29 16:58:13 EST
Upstream writes :

« As I can see, you are using original xkb configuration database (not
xkeyboard-config). And it may be broken in many ways. Would you consider trying
xkeyboard-config?

http://www.freedesktop.org/wiki/Software_2fXKeyboardConfig

http://xlibs.freedesktop.org/xkbdesc/xkeyboard-config-0.7.tar.bz2 »

and closed the bug as NOTGNOME

So either Fedora ships xkeyboard-config or it needs to convince Gnome people to
support the xorg xkbdata (difficult since the gnome applet maintainer is also an
xkeyboard-config maintainer)

-> back to xorg-xkbdata
Comment 2 Mike A. Harris 2005-12-29 17:18:36 EST
Fedora Core development, ships the stock unmodifiied X.Org xkbdata package
that comes as part of the modular X11R7 release.  We do not ship the
xkeyboard-config data at this stage in time.

What is GNOME currently using/expecting exactly?
Comment 3 Nicolas Mailhot 2005-12-30 04:26:45 EST
It's all in the referenced Gnome bug (which was just closed as NOTGNOME)

http://bugzilla.gnome.org/show_bug.cgi?id=323210

I don't care myself which xkbdata Fedora actually uses, as long as Fedora apps
can work with it
Comment 4 Nicolas Mailhot 2006-01-07 05:39:33 EST
There is some progress, in latest rawhide the applet manages to grab keyboard
lists somewhere. But :
1. you can't switch from the current keyboard to another even if you add it to
the switcher list (even the tuneable to select keypresses to switch keymaps is gone)
2. A sure way to kill your session is to select "let the server manager ctrl +
alt". Very strange boog, looks like gnome starts switching between themes madly
till the session decides it has enough

So the keyboard applet is still dead in the water post xorg 7.0
Comment 5 Ray Strode [halfline] 2006-02-10 14:02:22 EST
the strange bug is probably gnome-settings-daemon crashing over and over again
(probably in libxklavier)
Comment 6 Matthias Clasen 2006-02-14 15:34:12 EST
*** Bug 176002 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2006-02-21 05:33:39 EST
(In reply to comment #1)
> Upstream writes :
> 
> « As I can see, you are using original xkb configuration database (not
> xkeyboard-config). And it may be broken in many ways. Would you consider trying
> xkeyboard-config?
> 
> http://www.freedesktop.org/wiki/Software_2fXKeyboardConfig
> 
> http://xlibs.freedesktop.org/xkbdesc/xkeyboard-config-0.7.tar.bz2 »
> 
> and closed the bug as NOTGNOME
> 
> So either Fedora ships xkeyboard-config or it needs to convince Gnome people to
> support the xorg xkbdata (difficult since the gnome applet maintainer is also an
> xkeyboard-config maintainer)
> 
> -> back to xorg-xkbdata

This is quite an interesting hot-potato toss.  The official X.Org X11R7
release ships "xkbdata", which is what is in Fedora Core 5.  It is way
beyond the feature freeze dates to switch to xkeyboard-config for FC5,
or to include it even as an option at this point.

So we are stuck shipping xkbdata in FC5.  If the GNOME project wont support
the xkbdata that is shipped in X.Org X11R7, then it appears this problem
is unresolveable until FC6.

Removing from FC5Target tracker.

Comment 8 Simos Xenitellis 2006-02-25 14:55:56 EST
AFAIK, Xorg has been slow in adopting xkeyboard-config.
In any case I hope this gets resolved soon.
Comment 9 Alexandre Oliva 2006-03-01 15:08:24 EST
Dunno if it helps any, but today's xorg-x11-xkbdata claims to support
xkeyboard-config.  Unfortunately, that completely broke setxkbmap:

$ setxkbmap br
Couldn't interpret _XKB_RULES_NAMES property
Use defaults: rules - 'xorg' model - 'pc101' layout - 'us'

/usr/share/X11/xkb/rules/xorg* is not present any more, and setxkbmap needs it.

Needless to say, my br-abnt keyboard was partially broken as soon as I logged
in.  Keys such as those for / and pipe are broken.  Oddly, even if I downgrade
to yesterday's xorg-x11-xkbdata and re-run the command above, the pipe key is
still broken.
Comment 10 Ray Strode [halfline] 2006-03-01 15:12:28 EST
Hi,

The setxkbmap breakage should be fixed in tomorrow's rawhide.  a fixed package
is also attached to bug 183521, if you want to fix things now.
Comment 11 Nicolas Mailhot 2006-03-01 18:11:36 EST
My original bug is fixed thanks to xkeyboard-config, you can close the bug now
if you whish

The Gnome applet has resumed working (it behaves very strangely when you
add/remove layouts, seems to crash gconf repeatedly, but if you retry a few
times and restart X a few times too it finishes to stabilize working as it should)
Comment 12 Simos Xenitellis 2006-03-01 18:31:38 EST
(In reply to comment #11)
> The Gnome applet has resumed working (it behaves very strangely when you
> add/remove layouts, seems to crash gconf repeatedly, but if you retry a few
> times and restart X a few times too it finishes to stabilize working as it should)

I confirm that the Keyboard Indicator applet works now and the Layout Options
appear properly.

The /etc/X11/xorg.conf file shows correctly the layout as "us,gr" (for Greek).
However, the switching shortcut is listed as "shift" (Press both Shift keys to
switch). This key combination does not work. I am not sure if there are users
that use this combination.

In addition, the config file says the group led light is "scroll". However, it
does not lit up when I toggle group; it switches only when I toggle Caps Lock,
which is a (annoying) feature.
Comment 13 Alexandre Oliva 2006-03-02 08:33:42 EST
Works for me now, except for the crashes, now tracked at bug 183569.

Note You need to log in before you can comment on or make changes to this bug.