Bug 176023 - xpdf -fullscreen is no longer presentation mode (regression)
xpdf -fullscreen is no longer presentation mode (regression)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 13:24 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.02-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 23:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot that demonstrates the problem (48.95 KB, image/png)
2006-10-15 19:24 EDT, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2005-12-17 13:24:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
xpdf -fullscreen filename.pdf used to start xpdf in full-screen mode, displaying *only* the content of the pdf file, without any borders, buttons, anything.  In FC5, however, it does that for just a moment, and then shrinks the window and introduces the undesirable navigation bar below it.  Presentation mode should not contain such ugliness, and -fullscreen is documented in xpdf -help as presentation mode.

Version-Release number of selected component (if applicable):
xpdf-3.01-6

How reproducible:
Always

Steps to Reproduce:
1.Start xpdf -fullscreen filename.pdf

Actual Results:  It opens a full screen containing the pdf file, and then immediately shrinks it such that the lower navigation bar will fit.

Expected Results:  The way it used to be, without the navigation bar.

Additional info:

With evince incapable of displaying latex-formatted boxes properly and xpdf unable to enter presentation mode, there's no good PDF presentation tool left in FC :-(
Comment 1 Horst H. von Brand 2006-01-20 21:37:10 EST
Same thing here, xpdf-3.01-10
Comment 2 Alexandre Oliva 2006-02-28 21:25:01 EST
Still broken in today's rawhide.  At least fix the -help message, that says it
*is* presentation mode.  (although I'd much rather have the original behavior).
 evince is horribly broken (bug 166070), so that's not an option.  I'd even say
xpdf should be in the default install, given the state of evince.
Comment 3 Horst H. von Brand 2006-03-26 20:25:53 EST
Still here (or perhaps again?) with xpdf-3.01-12.1. At least evince-0.5.1-3
seems to work for presentations now...
Comment 4 Hans de Goede 2006-04-07 10:17:30 EDT
This is because the new Metacity causes problem with fullscreen apps, file a bug
against Metacity I guess, or fix all the apps SDL en allegro games still work.

From my games programming experience I know a thing or two about fullscreen mode
I can take a look at xpdf if someone can give me a pointer where to look, but
many more apps are broken, so it might be better to just reassign this to metacity.
Comment 5 Alexandre Oliva 2006-04-10 21:00:31 EDT
Hans, your comment does not make sense to me.  xpdf *does* enter full screen
mode, it's just that, right after doing so, it shrinks the full-screen panel to
make room for the control buttons, that were not supposed to be there in
presentation/full-screen mode.  I don't see what the window manager might have
to do with this, since we are in full screen mode, as far as the window manager
is concerned, one way or the other.  Or are we not?
Comment 6 Hans de Goede 2006-04-11 02:46:54 EDT
Sorry I misread, I though the gnome-panel was popping up, my bad. Please ignore
comment 4.
Comment 7 Alexandre Oliva 2006-06-17 14:14:55 EDT
Still broken in rawhide.
Comment 8 Alexandre Oliva 2006-07-27 00:32:39 EDT
<broken_record :->Still broken in rawhide</broken_record :-> (xpdf-3.01-15)
Comment 9 Tom "spot" Callaway 2006-10-10 13:36:38 EDT
Got a version where it isn't broken? :)
Comment 10 Alexandre Oliva 2006-10-10 15:47:02 EDT
The one that shipped with FC4 IIRC.
Comment 11 Tom "spot" Callaway 2006-10-12 00:32:40 EDT
That gives me a good place to start, thanks. I'll tackle this when I return from
vacation.
Comment 12 Tom "spot" Callaway 2006-10-15 19:10:34 EDT
OK, I'm not seeing a xpdf navigation bar in either the old xpdf or the current one.

xpdf-3.00 from FC-4 (rebuilt on FC-6):
http://people.redhat.com/tcallawa/old-xpdf-presentation.png
xpdf-3.01 from FE-6 (built for FC-6):
http://people.redhat.com/tcallawa/new-xpdf-presentation.png

The obvious difference is that the background is white and the document is on
the left side in the old xpdf version, whereas, the background is "grey" and the
document is centered in the new xpdf version.

Both versions respond to "n" and "p" to move to the next and previous pages,
respectively.

I'm having issues seeing a bug here, as opposed to a set of minor display
changes between xpdf 3.00 and 3.01. Do you have a PDF file that better
illustrates the bug here?

Comment 13 Alexandre Oliva 2006-10-15 19:24:09 EDT
Created attachment 138538 [details]
screenshot that demonstrates the problem

It's very odd that you can't duplicate the problem yourself.  Maybe it is some
configuration variable in /etc/xpdfrc or ~/.xpdfrc?  I don't have the latter. 
Could it possibly have to do with my Gnome panels being configured for
auto-hide?
Comment 14 Alexandre Oliva 2006-10-15 19:28:04 EDT
Hmm...  Did you try on x86 or x86_64?  I'm wondering if this is a 64-bit
issue...  The time I started having this problem might actually match the time
when I switched to a 64-bit notebook.  The dates don't look right, but hey! ;-)
Comment 15 Tom "spot" Callaway 2006-10-15 19:54:26 EDT
I tried on x86. I'm not sure exactly how this could be a 64-bit issue, but I'm
definitely not seeing the behavior that you are.

I don't have ~/.xpdfrc, and my /etc/xpdfrc is unmodified. I configued my Gnome
panels for autohide and it didn't change my results.

Got a 32bit system to test this on? :)
Comment 16 Horst H. von Brand 2006-10-15 20:47:32 EDT
I just tried on x86, and get the same results as Alexandre (xpdf navigation bar
is visible). And also the Gnome bars don't go away, as they should (they are
also visible in your examples in #12). No ~/.xpdfrc, package checks out clean
("rpm -V xpdf").

xpdf-3.01-26.fc6
Comment 17 Tom "spot" Callaway 2006-10-15 21:52:11 EDT
OK, there are two items in your comment:

- xpdf navigation bar is visible: What commandline string are you using? 
 I'm using xpdf -fullscreen FILE.pdf

- Gnome bars not going away: Both versions of xpdf do not seem to be doing
"true" fullscreen, but rather, occupying all of the screen space allotted for
applications, so this is a tangential issue.
Comment 18 Alexandre Oliva 2006-10-15 21:55:53 EDT
1. Same here, xpdf -fullscreen FILE.pdf

2. I don't care about the gnome panels remaining in place, indeed.
Comment 19 Horst H. von Brand 2006-10-15 23:19:04 EDT
re 1: xpdf -fullscreen FILE.pdf

re 2: I /do/ care if the Gnome bars showing up. E.g. OO impress or evince don't
leave them on screen. Is that another bug, that should be filed separately?
Comment 20 Tom "spot" Callaway 2006-10-15 23:26:20 EDT
Yes, the "fullscreen is not *true* fullscreen merits its own bug".

This bug is really "why are there ugly controls in fullscreen mode". Which, I
can't reproduce on my laptop. I'll try some other machines later in the week.
Comment 21 Fedora Update System 2007-08-01 23:42:50 EDT
xpdf-3.02-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.