Bug 176041 - udev_db_lookup_name: unable to open udev_db '/dev/.udev/db'
udev_db_lookup_name: unable to open udev_db '/dev/.udev/db'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 176547 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 01:41 EST by Stephen Warren
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 08:29:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2005-12-18 01:41:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051211 Fedora/1.5-1.1 Firefox/1.5

Description of problem:
When booting, I see the following messages on the console when starting udev:

Starting udev:udevd-event[745]: udev_db_lookup_name: unable to open udev_db '/de
v/.udev/db': No such file or directory

(the error message is repeated twice)

Not that there is such a directory:

[root@esk .udev]# ls -ld /dev/.udev/
drwxr-xr-x 4 root root 80 Dec 17 23:18 /dev/.udev/
[root@esk .udev]# ls -ld /dev/.udev/db
drwxr-xr-x 2 root root 720 Dec 17 23:17 /dev/.udev/db



Version-Release number of selected component (if applicable):
udev-077-1

How reproducible:
Always

Steps to Reproduce:
1. Boot PC, watch console soon before switch to X (due to rhgb)


Additional info:
Comment 1 Stephen Warren 2005-12-18 01:55:16 EST
FYI, just updated udev and kernel, and it still happens with:
udev-077-2
kernel-2.6.14-1.1770_FC5
Comment 2 Kay Sievers 2005-12-20 21:46:48 EST
This is caused by executing udevinfo while there is no database to read. udev
078 exports the symlinks to the event environment and calling udevinfo is not
needed. I've also removed the error log for the next udev version.
Comment 3 Harald Hoyer 2005-12-21 04:39:14 EST
hmm, there is no script in the udev package, that calls udevinfo during system
startup...
Comment 4 Kay Sievers 2005-12-21 05:05:40 EST
Don't you call pam_console.dev anymore? It was calling udevinfo in the past.
Comment 5 Clyde E. Kunkel 2005-12-21 10:34:15 EST
I am seeing this also as: 

Starting udev:udevd-event[944]: udev_db_lookup_name: unable to open udev_db
'/dev/.udev/db': No such file or directory

/dev/.udev/db is there, but I don't know when it is created. Also, I don't see
any errors after booting and starting work.  Nothing in any of the logs.


Comment 6 Clyde E. Kunkel 2006-01-05 20:45:40 EST
Saw this today (1/5/2006) on a clean install of rawhide.
Comment 7 Harald Hoyer 2006-01-11 05:08:22 EST
*** Bug 176547 has been marked as a duplicate of this bug. ***
Comment 8 Harald Hoyer 2006-01-11 05:10:27 EST
pam_console.dev now uses $DEVLINKS, no udevinfo involved.
Comment 9 Clyde E. Kunkel 2006-01-16 13:01:46 EST
Still present on clean install of FC5T2.  Not every reboot, tho.  Can't predict
when the problem will occur.
Comment 10 Warren Togami 2006-01-16 21:55:21 EST
I've seen this happen after my laptop lost power.  The next boot had this
problem, and haldaemon wouldn't run.  Rebooting fixed it.
Comment 11 Reuben Farrelly 2006-01-21 07:04:14 EST
I suspect this is fixed in later versions of udev:

From udev-081/ChangeLog

----

Summary of changes from v078 to v079
============================================

Kay Sievers:
      don't log error if database does not exist
      <snip>

----

Of course current rawhide has 078, so a jump to 081 would probably solve this one.

Note You need to log in before you can comment on or make changes to this bug.