Bug 176059 - missing acpi component file in 1653
missing acpi component file in 1653
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 12:45 EST by jmw
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 19:00:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmw 2005-12-18 12:45:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
upgrade kernel on Dell I7500 laptop, through YUM-X.  on boot-up with 1653, i see an error message similar to:

"...missing file acpi_cpufreq.ko"

this component file exists for versions 1456 and 1644 on the same machine.  also, the component file did get installed for version 1653 on a Dell PW410 machine (PW410 is dual processor).

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1653_FC4

How reproducible:
Always

Steps to Reproduce:
1. boot to 1653
2. see error message on-screen
3.
  

Actual Results:  no obvious problem so far, on usual use of the machine.

Expected Results:  it seems that 'acpi_cpufreq.ko' was installed for two previous versions, so i expect it should have been installed on upgrade to 1653.

Additional info:
Comment 1 Dave Jones 2005-12-19 22:58:07 EST
I've no idea what 'yum-x' is, but that's my suspect right now, as this is the
only report of this bug, and that file is installed on every one of my test
boxes fine.

can you try..

rpm -e kernel-2.6.14-1.1653_FC4
yum update kernel
Comment 2 jmw 2005-12-20 10:33:10 EST
'yum-x' == my shorthand for "YUM Extender", sometimes known as "YumEx".  it's
the GUI-based version of Yum.  i'll spell it out next time.  meanwhile...

ran 'rpm -e', then 'yum update kernel'.  same result.  i don't find the full
error message in /var/log, but at boot-up the line reads:
"FATAL: error inserting <path to file>acpi_cpufreq.ko, no such device"

so far, i don't find any other problem with machine operation.  i don't know
what this file is or should do.  it did get installed in previous kernel
versions, so unless there is a change i suppose i could simply copy the 1644
version to the 1653 path, but i'd prefer to understand why it's dropped or
ignored during update.

for what it's worth, from Google:
Results 1 - 9 of about 25 for acpi_cpufreq.ko +error. (0.75 seconds) 
Comment 3 jmw 2005-12-20 13:52:22 EST
i spent a bit more time on this.  after the 'rpm -e'/'yum install' exercise, i
now find the 1653 version of acpi_cpufreq.ko on the system.  however, there is
still a "fatal" error message on boot-up, immediately following a "Checking for
new hardware" line.  if i boot to 1644 instead, there is no error message.  just
for grins, i ran 'updatedb', no effect.

so, it seems the file is present, but i get an error message on boot.  up to
now, i still don't find a system problem that i can attribute to this device
file and don't understand why there was no message for 1644 and earlier but
there is one now.
Comment 4 jmw 2005-12-22 16:58:37 EST
i decided to try acpi options for 1653.  now, i find that if i set acpi=off,
there is no error message on boot-up.  my guess is some combination of:

a. there is some kind of problem in acpi_cpufreq.ko for 1653, but not for 1644
or 1456, or...
b. the component file is fine, but there is some problem in kernel 1653 (acpi
appears to be causing some kind of problem in 1653 SMP. are the two conditions
related?)
c. the component file is fine, the kernel is fine, the feature was disabled in
earlier versions; that's why it looks like it's now broken.

lastly: bad guesswork, all of the above.  it's something else.
Comment 5 Dave Jones 2005-12-23 14:53:54 EST
in previous kernels there was a check in the ACPI code for a BIOS with a
manufacture date of '2000' or earlier. If we found the date was <= 2000, we
disabled acpi.  The latest update disabled this check, as it's believed that the
acpi interpretor has got better with age, and a lot of things that were
previously thought to be bios bugs were in fact, kernel bugs that are now fixed.

It turns out that there's a few rough edges here and there that still need
fixing up.  The good news is that the acpi-cpufreq message is just a harmless
warning. I'll be pushing out a cpuspeed update for fc4 soon, which should make
it go away.
Comment 6 jmw 2005-12-23 15:58:37 EST
ah! ...so, some of my guesswork was close, after all.  i do recall seeing some
message about "<=2000" on boot-up, in earlier versions.  i had ignored that up
to now.

thanks for the update.  i'll just look for the later release.
Comment 7 Dave Jones 2006-02-03 00:44:26 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.