Bug 1761389 - external gateway connectivity lost when adding external subnets [NEEDINFO]
Summary: external gateway connectivity lost when adding external subnets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z11
: 13.0 (Queens)
Assignee: ffernand
QA Contact: eolivare
URL:
Whiteboard:
Depends On:
Blocks: 1761397 1761400 1761419
TreeView+ depends on / blocked
 
Reported: 2019-10-14 10:25 UTC by ffernand
Modified: 2020-03-10 11:27 UTC (History)
4 users (show)

Fixed In Version: python-networking-ovn-4.0.3-15.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1761397 1761400 1761419 (view as bug list)
Environment:
Last Closed: 2020-03-10 11:26:10 UTC
Target Upstream Version:
jamsmith: needinfo? (ffernand)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1843485 0 None None None 2019-10-14 10:32:03 UTC
OpenStack gerrit 688003 0 'None' MERGED Do not lose router logical port upon subnet add on the external net 2020-03-05 17:21:17 UTC
Red Hat Product Errata RHBA-2020:0770 0 None None None 2020-03-10 11:27:01 UTC

Description ffernand 2019-10-14 10:25:59 UTC
Description of problem:

If we attach a subnet to that external network afterwards, the northbound
database loses that logical port, together with the row in the gateway_chassis table.

Version-Release number of selected component (if applicable):
OSP13 (all versions)

How reproducible:
Always

Steps to Reproduce:

openstack network create public --external --default --provider-network-type vlan --provider-physical-network tenant --provider-segment 1099

openstack router create myrouter

EXT_NET_ID=$(openstack network show public -f value -c id)
openstack router set --external-gateway $EXT_NET_ID myrouter

Actual results:

We lose connectivity on all external subnets, because the router logical port is lost

Expected results:

User should be able to set subnets after creating and attaching external networks to router


Additional info:

See launchpad for more details on what the sequence of events cause this.

Comment 1 ffernand 2019-10-14 11:08:40 UTC
When router has a port set as external gateway, a logical port is created on the logical_router
in the nortbound database, as expected.

However, if we attach a subnet to that external network afterwards, the northbound
database loses that logical port, together with the row in the gateway_chassis table.

Comment 4 eolivare 2020-02-14 09:52:20 UTC
Verified on OSP13 2020-02-10.8 puddle with python-networking-ovn-4.0.4-2.el7ost.noarch

- Router connected to external network
- Added subnet1 with existing VM instances - external connectivity OK
- Added subnet2 without VM instances - external connectivity OK (checked from previous VM instances)
- Added IPV6 subnet - external connectivity OK

No logical port was lost from this logical router during the test. Instead, new ports and nats were added with every new subnet.

Comment 7 errata-xmlrpc 2020-03-10 11:26:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0770


Note You need to log in before you can comment on or make changes to this bug.