Bug 1761400 - external gateway connectivity lost when adding external subnets
Summary: external gateway connectivity lost when adding external subnets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: ffernand
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On: 1761389 1761419
Blocks: 1761397
TreeView+ depends on / blocked
 
Reported: 2019-10-14 10:42 UTC by ffernand
Modified: 2020-03-05 11:54 UTC (History)
9 users (show)

Fixed In Version: python-networking-ovn-6.0.1-0.20191014220426.7e5df26.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1761389
Environment:
Last Closed: 2020-03-05 11:53:50 UTC
Target Upstream Version:
ffernand: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1843485 0 None None None 2019-10-14 10:42:20 UTC
OpenStack gerrit 688001 0 'None' MERGED Do not lose router logical port upon subnet add on the external net 2020-03-04 20:58:51 UTC
Red Hat Product Errata RHBA-2020:0709 0 None None None 2020-03-05 11:54:15 UTC

Description ffernand 2019-10-14 10:42:21 UTC
+++ This bug was initially created as a clone of Bug #1761389 +++

Description of problem:

If we attach a subnet to that external network afterwards, the northbound
database loses that logical port, together with the row in the gateway_chassis table.

Version-Release number of selected component (if applicable):
OSP13 (all versions)

How reproducible:
Always

Steps to Reproduce:

openstack network create public --external --default --provider-network-type vlan --provider-physical-network tenant --provider-segment 1099

openstack router create myrouter

EXT_NET_ID=$(openstack network show public -f value -c id)
openstack router set --external-gateway $EXT_NET_ID myrouter

Actual results:

We lose connectivity on all external subnets, because the router logical port is lost

Expected results:

User should be able to set subnets after creating and attaching external networks to router


Additional info:

See launchpad for more details on what the sequence of events cause this.

Comment 3 Roman Safronov 2019-12-30 16:53:24 UTC
Verified on 15.0-RHEL-8/RHOS_TRUNK-15.0-RHEL-8-20191223.n.1 with python3-networking-ovn-6.0.1-0.20191218220439.deb9efe.el8ost.noarch

Verified that router with attached external network does not lose the logical port after adding an external subnet.

Comment 4 Alex McLeod 2020-02-19 12:48:32 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to '-'.

Comment 7 errata-xmlrpc 2020-03-05 11:53:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0709


Note You need to log in before you can comment on or make changes to this bug.