Bug 1761616 - Installing all ceph roles to a single host (all-in-one) fails
Summary: Installing all ceph roles to a single host (all-in-one) fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 4.0
Assignee: Paul Cuzner
QA Contact: Vasishta
URL:
Whiteboard:
Depends On: 1787068
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-14 21:51 UTC by Paul Cuzner
Modified: 2020-01-31 12:47 UTC (History)
7 users (show)

Fixed In Version: cockpit-ceph-installer-0.9-2.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:46 UTC

Description Paul Cuzner 2019-10-14 21:51:31 UTC
Description of problem:
When only one host is used for all ceph roles, the default crush rules prevent PGs from peering which blocks.fails the installation.

Version-Release number of selected component (if applicable):
ceph-cockpit-installer-0.9-1

How reproducible:
100%

Steps to Reproduce:
1. Perform an all-in-one (AIO) install, selecting all roles on a songle host
2.
3.

Actual results:
instllation fails, ceph stuck in a warn state, pg's unable to peer

Expected results:
For a development type installation, a single host deployment should be supported and installation should succeed.

Additional info:

Comment 1 Paul Cuzner 2019-10-15 22:51:45 UTC
fixed in upstream commit dd4693b6e4b2e04ed901c768bd1ee2201ee5a2c2

Comment 9 errata-xmlrpc 2020-01-31 12:47:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.