Bug 1761689 - [Feature:DeploymentConfig] deploymentconfigs adoption [Conformance] will orphan all RCs and adopt them back when recreated [Suite:openshift/conformance/parallel/minimal]
Summary: [Feature:DeploymentConfig] deploymentconfigs adoption [Conformance] will orph...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard: workloads
: 1749239 1765283 (view as bug list)
Depends On:
Blocks: 1772087
TreeView+ depends on / blocked
 
Reported: 2019-10-15 05:52 UTC by xiyuan
Modified: 2020-01-23 11:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1772087 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:07:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24128 'None' closed Bug 1761689: Fix RS expectations for recreate case 2020-02-28 14:59:37 UTC
Github openshift origin pull 24177 'None' closed Bug 1761689: Fix RS expectations for recreate case 2020-02-28 14:59:38 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:08:05 UTC

Description xiyuan 2019-10-15 05:52:32 UTC
Description of problem:
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-rhel7-workers-4.2/1

fail [github.com/openshift/origin/test/extended/deployments/deployments.go:1671]: Unexpected error:
    <*errors.errorString | 0xc0002aeca0>: {
        s: "timed out waiting for the condition",
    }
    timed out waiting for the condition
occurred

Version-Release number of selected component (if applicable):
4.2 jobs

Comment 2 Tomáš Nožička 2019-11-11 08:27:24 UTC
I think it is this one https://github.com/kubernetes/kubernetes/pull/82572, updated the upstream PR, we should get it shortly after as a backport to stabilize CI

Comment 3 Tomáš Nožička 2019-11-11 08:29:51 UTC
*** Bug 1765283 has been marked as a duplicate of this bug. ***

Comment 4 Tomáš Nožička 2019-11-11 15:39:57 UTC
*** Bug 1749239 has been marked as a duplicate of this bug. ***

Comment 6 zhou ying 2019-11-20 10:17:26 UTC
With latest code, I could run the automation successful.

Comment 7 Tomáš Nožička 2019-11-20 11:23:44 UTC
the fix was nuked 5 days back by another PR, this should have failed until https://github.com/openshift/origin/pull/24177 brings it back

Comment 9 zhou ying 2019-11-26 07:41:05 UTC
Confirmed with latest origin, the PR has merged , with the latest version, the issue can't be reproduced.

Comment 10 zhou ying 2019-11-26 07:41:17 UTC
Confirmed with latest origin, the PR has merged , with the latest version, the issue can't be reproduced.

Comment 11 Miciah Dashiel Butler Masters 2019-12-20 23:20:55 UTC
I saw this today:

    [Feature:DeploymentConfig] deploymentconfigs adoption [Conformance] will orphan all RCs and adopt them back when recreated [Suite:openshift/conformance/parallel/minimal] expand_less	2m8s
    fail [github.com/openshift/origin/test/extended/deployments/deployments.go:1671]: Unexpected error:
        <*errors.errorString | 0xc0002b9340>: {
            s: "timed out waiting for the condition",
        }
        timed out waiting for the condition
    occurred

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-shared-vpc-4.3/310

Is it the same issue, or should I open a new report?

Comment 12 Tomáš Nožička 2020-01-08 11:21:00 UTC
Dec 20 15:11:40.572: INFO: wait: LatestVersion: 2
STEP: making sure DC can be scaled
[AfterEach] adoption [Conformance]
  /go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/deployments/deployments.go:1560
Dec 20 15:12:10.830: INFO: Running 'oc --namespace=e2e-test-cli-deployment-tcshv --config=/tmp/configfile013024021 get dc/deployment-simple -o yaml'

Miciah, I think it is a different one - likely the platform load balancer killing long lived connections after 30 sec https://bugzilla.redhat.com/show_bug.cgi?id=1788253

Comment 14 errata-xmlrpc 2020-01-23 11:07:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.