Bug 1761814 - Informers can miss notifications
Summary: Informers can miss notifications
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.2.z
Assignee: Lukasz Szaszkiewicz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On: 1761815
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-15 12:48 UTC by Lukasz Szaszkiewicz
Modified: 2019-11-13 18:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1761809
: 1761815 (view as bug list)
Environment:
Last Closed: 2019-11-13 18:55:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 23965 0 'None' 'closed' 'Bug 1761814: Informers can miss notifications' 2019-11-29 12:30:31 UTC
Red Hat Bugzilla 1761815 0 unspecified CLOSED Informers can miss notifications 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2019:3303 0 None None None 2019-11-13 18:56:02 UTC

Description Lukasz Szaszkiewicz 2019-10-15 12:48:03 UTC
Description of problem: Informers can miss notifications about object creation. The issue is well described and marked as critical - https://github.com/kubernetes/kubernetes/pull/83911. The issue affects all components that use informers like controllers, API servers, etc.

Comment 2 Xingxing Xia 2019-10-30 08:43:03 UTC
Like the 4.3 bug 1761815#c1 , checked some regression test in recent 4.2 new payload jobs https://testgrid.k8s.io/redhat-openshift-release-4.2-informing-ocp , no issue found related. Thus changing bug status to VERIFIED.

Comment 4 errata-xmlrpc 2019-11-13 18:55:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3303


Note You need to log in before you can comment on or make changes to this bug.