Bug 1761815 - Informers can miss notifications
Summary: Informers can miss notifications
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1761809 1761814
TreeView+ depends on / blocked
 
Reported: 2019-10-15 12:51 UTC by Lukasz Szaszkiewicz
Modified: 2020-01-23 11:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1761814
Environment:
Last Closed: 2020-01-23 11:07:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 23963 0 'None' closed UPSTREAM: 83911: Fix DeltaFIFO Replace method to prevent SharedIndexInformers from missing notifications 2020-03-09 08:52:27 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:08:05 UTC

Internal Links: 1761809 1761814

Description Lukasz Szaszkiewicz 2019-10-15 12:51:38 UTC
Description of problem: Informers can miss notifications about object creation. The issue is well described and marked as critical - https://github.com/kubernetes/kubernetes/pull/83911. The issue affects all components that use informers like controllers, API servers, etc.

Comment 4 errata-xmlrpc 2020-01-23 11:07:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.