Bug 176184 - Make chkconfig without arguments the same as --list
Make chkconfig without arguments the same as --list
Status: CLOSED DUPLICATE of bug 290241
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 16:02 EST by Brad Ritchie
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 16:51:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Ritchie 2005-12-19 16:02:05 EST
Description of problem:
=======================
The --list option to chkconfig is cumbersome to use from the shell when
constantly making changes and verifying the status of services.  It would be
nice if chkconfig listed the service by default when no arguments (on|off|reset)
were given.  Currently, chkconfig without any options is the same as "chkconfig
--help".  This change would make chkconfig without any arguments behave the same
as "chkconfig --list".  Users would be required to explicitly enter "chkconfig
--help" to get usage info, but this is consistent with current conventions.

Ideally, this would work for individual services as well (eg. "chkconfig sshd"
would list the status for the sshd service), but this form is currently used as
a test to see if a service is enabled or not, based on it's return value.

In addition, it would convenient if all options (--list, --add, --del, --level)
allowed a single-letter short form. (eg. -l, -a, -d, -L).  These are just
suggestions... they're not necessarily intuitive (-d could be confused for
"debug") but they make command-line editing easier in the case of --list, they
follow the standard (old-school) convention and are supported by the popt library.


Version-Release number of selected component (if applicable):
=============================================================
chkconfig version 1.3.23 - Copyright (C) 1997-2000 Red Hat, Inc.
Comment 1 Bill Nottingham 2007-11-08 16:51:53 EST
Will be in 1.3.37-1.

*** This bug has been marked as a duplicate of 290241 ***

Note You need to log in before you can comment on or make changes to this bug.