Bug 290241 - Enhancement to chkconfig - imply list when no action specified
Summary: Enhancement to chkconfig - imply list when no action specified
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 176184 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-13 23:01 UTC by Mark D. Foster
Modified: 2014-03-17 03:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 21:51:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against chkconfig-1.3.30.1 (3.84 KB, patch)
2007-09-13 23:01 UTC, Mark D. Foster
no flags Details | Diff
patch for this (2.45 KB, patch)
2007-11-08 21:37 UTC, Bill Nottingham
no flags Details | Diff

Description Mark D. Foster 2007-09-13 23:01:37 UTC
Description of problem:
This patch enables chkconfig to act more like the IRIX version it is said to be
based on. If none of --list, --add or --del are passed, --list is implied.

Version-Release number of selected component (if applicable):
1.3.30.2

How reproducible:
Apply patch (attached)

Actual results:
# /sbin/chkconfig  ntpd                                            ntpd        
   0:off   1:off   2:on    3:on    4:on    5:on    6:off

# /sbin/chkconfig
NetworkManager  0:off   1:off   2:off   3:off   4:off   5:off   6:off
NetworkManagerDispatcher        0:off   1:off   2:off   3:off   4:off   5:off  
6:off
acpid           0:off   1:off   2:off   3:on    4:on    5:on    6:off
anacron         0:off   1:off   2:on    3:on    4:on    5:on    6:off
apmd            0:off   1:off   2:on    3:on    4:on    5:on    6:off
atd             0:off   1:off   2:off   3:on    4:on    5:on    6:off
auditd          0:off   1:off   2:on    3:on    4:on    5:on    6:off
autofs          0:off   1:off   2:on    3:on    4:on    5:on    6:off
...[output trimmed for brevity]
Additional info:

Comment 1 Mark D. Foster 2007-09-13 23:01:37 UTC
Created attachment 195341 [details]
patch against chkconfig-1.3.30.1

Comment 2 Mark D. Foster 2007-09-13 23:47:34 UTC
Please note that this partially covers the RFE in #176184

Comment 3 Bill Nottingham 2007-11-08 21:18:16 UTC
chkconfig <service> is designed to explicitly query whether a service is set up
for the current runlevel - I'd like to keep that behavior.

Comment 4 Bill Nottingham 2007-11-08 21:37:25 UTC
Created attachment 252191 [details]
patch for this

Here's what will be in 1.3.37-1.

Comment 5 Bill Nottingham 2007-11-08 21:51:54 UTC
*** Bug 176184 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.