Bug 1761921 - Manifest lists are not copied by oc image mirror or oc adm release mirror
Summary: Manifest lists are not copied by oc image mirror or oc adm release mirror
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Clayton Coleman
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1761922
TreeView+ depends on / blocked
 
Reported: 2019-10-15 15:09 UTC by Clayton Coleman
Modified: 2020-01-23 11:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1761922 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:07:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:08:05 UTC

Description Clayton Coleman 2019-10-15 15:09:21 UTC
When attempting to mirror a manifest list with --filter-by-os=.*, the command can fail if some manifests didn't already exist.  The image mirror command must properly upload manifest lists.

oc image mirror library/busybox:latest --filter-by-os=.* quay.io/myrepo/test:other

needs to copy the dependent manifests first.

This needs to be backported to 4.2 for people dealing with offline clusters.

Comment 2 zhou ying 2019-10-24 09:22:43 UTC
Confirmed with latest oc client, the issue has fixed:
[root@dhcp-140-138 ~]# oc version -o yaml 
clientVersion:
  buildDate: "2019-10-24T01:16:52Z"
  compiler: gc
  gitCommit: 8bf0a6cf35883df6e739e4b5e36c2d185e88d46e
  gitTreeState: clean
  gitVersion: v4.3.0
  goVersion: go1.12.8
  major: ""
  minor: ""
  platform: linux/amd64


[root@dhcp-140-138 ~]# oc image mirror library/busybox:latest --filter-by-os=.*   docker.io/zhouying7780/buxtest:16
docker.io/
  zhouying7780/buxtest
    blobs:
      library/busybox sha256:7afde900ce2961a4a523b9ffde6c74885d35ee4a34750804522cda6cfef6fc49 1.458KiB
      library/busybox sha256:2b6a7ffffc08fac0c40c19604a4e7fca8b8d22fe92264ed8bf94955e4303c44e 1.46KiB
      library/busybox sha256:a3c3934391ab4257a9827ef49727218d2e1bc98d2e08966e22a8449f8b9099c5 1.46KiB
      library/busybox sha256:b0a65db24ec4e999697c56e36ff9aae72a7e94cd3a9cae942c85145075670a1d 1.46KiB
      library/busybox sha256:0099567e3ee43a3978b21e858117c524137701c31ebacbdce44252df5ef1012b 1.462KiB
      library/busybox sha256:19485c79a9bbdca205fce4f791efeaa2a103e23431434696cc54fdd939e9198d 1.462KiB
      library/busybox sha256:6267a9e8448754a6a061116937cdb9bf3b52d63c6ab52efb688f9b734e3ae8d8 1.462KiB
      library/busybox sha256:ef978ee690808f750e25a87b3999d2d98dfb5222920012eb4236e30498eec891 1.464KiB
      library/busybox sha256:5353fef96f4f2d604443d34ab19d28b5247328ef4d3a24f49ab801656086514e 694.3KiB
      library/busybox sha256:00183cea3d518e4f5e112f7e79b148b25c6e470219acbd47f522fe8495860b85 705.7KiB
      library/busybox sha256:0d4d9f49ec28a1ea86f4354566b98528011c4367e6f70fd33eb461eafb980cc2 725.3KiB
      library/busybox sha256:7c9d20b9b6cda1c58bc4f9d6c401386786f584437abbe87e58910f8a9a15386b 742.9KiB
      library/busybox sha256:20f390519e2a095ea2543ea3e868497ec43892872622e585be962b299b538067 795.9KiB
      library/busybox sha256:2650400db2fd3f3a9348715eabfabe7faeee4cff2cb14d4f8cd3016fe15a1ee6 891.9KiB
      library/busybox sha256:6d4c3d9fc9157fc27f83e4ac41c5bc3b22bd3178ce92c05168837ba01272511e 2.038MiB
      library/busybox sha256:e38168a01e65ae0290ca0cc67e725f2a8c7d4b4c8b0ad2ac0b532fa37b960e43 2.499MiB
    manifests:
      sha256:2b8b3e1724e50bd44e5af5d54ce75a033a0a5f3f69f1d6aab744e053ddc96959
      sha256:655e7fa8b6e62b50b3586b51537bc00bd115f65433479e6b776327f36adb3b14
      sha256:a89f4d90296465ee222783760ba855e0dc3538c01a114803b6982ae678fca671
      sha256:b2b91f4b65ee15398cf683710a5ca645483d0d35c4adf7c15fb5a32526db9e1b
      sha256:b6e25123419cbaa5f07cf8e1a8b2e813cc6e7939b6c0d38161c7cfa435dbdc8d
      sha256:b88b0b701352a695cfe12b5804f389a0ef13cde842fb9ddbc2aabdb5ccbd852d
      sha256:dd7d9dbec04de7a1710de2e11ba0fd19c21caab20af2114699cef1ceab98f81a
      sha256:dd97a3fe6d721c5cf03abac0f50e2848dc583f7c4e41bf39102ceb42edfd1808
      sha256:fe301db49df08c384001ed752dff6d52b4305a73a7f608f21528048e8a08b51e
      sha256:fe301db49df08c384001ed752dff6d52b4305a73a7f608f21528048e8a08b51e -> 16
  stats: shared=0 unique=16 size=8.998MiB ratio=1.00

phase 0:
  docker.io zhouying7780/buxtest blobs=16 mounts=0 manifests=10 shared=0

info: Planning completed in 8.92s
uploading: docker.io/library/zhouying7780/buxtest sha256:5353fef96f4f2d604443d34ab19d28b5247328ef4d3a24f49ab801656086514e 694.3KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:7c9d20b9b6cda1c58bc4f9d6c401386786f584437abbe87e58910f8a9a15386b 742.9KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:e38168a01e65ae0290ca0cc67e725f2a8c7d4b4c8b0ad2ac0b532fa37b960e43 2.499MiB
uploading: docker.io/library/zhouying7780/buxtest sha256:2650400db2fd3f3a9348715eabfabe7faeee4cff2cb14d4f8cd3016fe15a1ee6 891.9KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:0d4d9f49ec28a1ea86f4354566b98528011c4367e6f70fd33eb461eafb980cc2 725.3KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:00183cea3d518e4f5e112f7e79b148b25c6e470219acbd47f522fe8495860b85 705.7KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:6d4c3d9fc9157fc27f83e4ac41c5bc3b22bd3178ce92c05168837ba01272511e 2.038MiB
uploading: docker.io/library/zhouying7780/buxtest sha256:20f390519e2a095ea2543ea3e868497ec43892872622e585be962b299b538067 795.9KiB
sha256:b2b91f4b65ee15398cf683710a5ca645483d0d35c4adf7c15fb5a32526db9e1b docker.io/library/zhouying7780/buxtest
sha256:b6e25123419cbaa5f07cf8e1a8b2e813cc6e7939b6c0d38161c7cfa435dbdc8d docker.io/library/zhouying7780/buxtest
sha256:655e7fa8b6e62b50b3586b51537bc00bd115f65433479e6b776327f36adb3b14 docker.io/library/zhouying7780/buxtest
sha256:b88b0b701352a695cfe12b5804f389a0ef13cde842fb9ddbc2aabdb5ccbd852d docker.io/library/zhouying7780/buxtest
sha256:dd97a3fe6d721c5cf03abac0f50e2848dc583f7c4e41bf39102ceb42edfd1808 docker.io/library/zhouying7780/buxtest
sha256:2b8b3e1724e50bd44e5af5d54ce75a033a0a5f3f69f1d6aab744e053ddc96959 docker.io/library/zhouying7780/buxtest
sha256:dd7d9dbec04de7a1710de2e11ba0fd19c21caab20af2114699cef1ceab98f81a docker.io/library/zhouying7780/buxtest
sha256:a89f4d90296465ee222783760ba855e0dc3538c01a114803b6982ae678fca671 docker.io/library/zhouying7780/buxtest
sha256:fe301db49df08c384001ed752dff6d52b4305a73a7f608f21528048e8a08b51e docker.io/library/zhouying7780/buxtest:16
info: Mirroring completed in 16.77s (562.6kB/s)

Comment 4 errata-xmlrpc 2020-01-23 11:07:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.