Bug 1761922 - Manifest lists are not copied by oc image mirror or oc adm release mirror
Summary: Manifest lists are not copied by oc image mirror or oc adm release mirror
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.2.z
Assignee: Clayton Coleman
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1761921
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-15 15:09 UTC by Clayton Coleman
Modified: 2019-12-20 00:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1761921
Environment:
Last Closed: 2019-12-20 00:46:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 128 'None' closed Bug 1761922: Manifest lists can fail to mirror because dependent manifests are not uploaded 2020-06-25 16:15:16 UTC
Red Hat Product Errata RHBA-2019:4181 None None None 2019-12-20 00:46:57 UTC

Description Clayton Coleman 2019-10-15 15:09:51 UTC
+++ This bug was initially created as a clone of Bug #1761921 +++

When attempting to mirror a manifest list with --filter-by-os=.*, the command can fail if some manifests didn't already exist.  The image mirror command must properly upload manifest lists.

oc image mirror library/busybox:latest --filter-by-os=.* quay.io/myrepo/test:other

needs to copy the dependent manifests first.

This needs to be backported to 4.2 for people dealing with offline clusters.

Comment 2 zhou ying 2019-12-11 07:28:12 UTC
confirmed with latest version, the issue has fixed:

[root@dhcp-140-138 ~]# oc version  -o yaml
clientVersion:
  buildDate: "2019-12-09T17:51:35Z"
  compiler: gc
  gitCommit: 98a84c615641b47ba5d6f405188e61e6f700798b
  gitTreeState: clean
  gitVersion: v4.2.11
  goVersion: go1.12.8
  major: ""
  minor: ""
  platform: linux/amd64

[root@dhcp-140-138 ~]# oc image mirror library/busybox:latest --filter-by-os=.*   docker.io/zhouying7780/buxtest:16
docker.io/
  zhouying7780/buxtest
    blobs:
      library/busybox sha256:cb41853d25da13681537252cb092560e8d7bae1464be98d1ece8a795084cec34 1.456KiB
      library/busybox sha256:5186b901b1f76bc08ca317cd25cc0fea4080c77aec333bb85c8fd06a8f5a4eb0 1.46KiB
      library/busybox sha256:a43f2517686425f470ea9cc3ef83c464531f2d00eb18dd4e027f9892c0ff2520 1.46KiB
      library/busybox sha256:fe024f3304273d9e3290322108156a849fd70fb3c94ce74d5b29cb35fa9e8d53 1.46KiB
      library/busybox sha256:7511c8913bc38f9295145e788c660a5b728863631455f4b494e3ae98523da300 1.462KiB
      library/busybox sha256:76aea076676891a4d49c28df8cad90948cb0319d546fe84f906f45638f694c2d 1.462KiB
      library/busybox sha256:b534869c81f05ce6fbbdd3a3293e64fd032e059ab4b28a0e0d5b485cf904be4b 1.462KiB
      library/busybox sha256:a2c8f0c248832d90446972b9ca5acdbb8cd44f2632c0d9c35e91a556339f894c 1.464KiB
      library/busybox sha256:b5a4eaa2659ece1708b67bb79c20a61a0fa3d00b9430ae0ad970ffb9ec085a05 694.3KiB
      library/busybox sha256:f9e04f2a560088ea8169cff8710b0edb5f319a0e10c160e26d98ef1ded50cccf 705.6KiB
      library/busybox sha256:a08f16ed68b26ecf1f02f9a0948f59060bce94ffee49f211eafdf840ed14fb4d 725.3KiB
      library/busybox sha256:322973677ef5fb0405c230fed304b2e907f46a1edb921bab269f88547bcf726f 743.1KiB
      library/busybox sha256:220602de6ed2e72ac3dead2002c03ab243dbaf27be9ed1b08b5588e52e4f20f1 796.8KiB
      library/busybox sha256:3eb12473a8208b6631651bb118954a7ec551ae6343bd1fb19b5603338b629582 892KiB
      library/busybox sha256:6dc7af96dfc85a47644373a0b98e836fd0c8aff6b6356418cba4ea7b46afc039 2.038MiB
      library/busybox sha256:d7e28ec550a2d3b32ddcda19c9c3af704b8b39977c6956b8f209f0d8b7fd719c 2.5MiB
    manifests:
      sha256:1828edd60c5efd34b2bf5dd3282ec0cc04d47b2ff9caa0b6d4f07a21d1c08084
      sha256:24fd20af232ca4ab5efbf1aeae7510252e2b60b15e9a78947467340607cd2ea2
      sha256:362ea5ff976609d3a811e5423bd8c11e1f031ae90ee823b1e56362dfe1d16d87
      sha256:50edf1d080946c6a76989d1c3b0e753b62f7d9b5f5e66e88bef23ebbd1e9709c
      sha256:59d479d844385faca8e6abce4df3ff3bcb54cc3ab6e7a51838c75f91451311b5
      sha256:7044f6fc222ac87449d87e041eae6b5254012a8b4cbbc35e5b317ac61aa12557
      sha256:7f0daf640bfd30871f64d8fe7d457931259b1c0aec5c929a8daabbe44c359337
      sha256:b19898c529964a48ce66923a06ddbde9cd5ae2472a42891b55cc00f7a60ba676
      sha256:cce548084ce402540134267ae6b98a9ce9273fcb57c801e07daeca7de2b2222b
      sha256:1828edd60c5efd34b2bf5dd3282ec0cc04d47b2ff9caa0b6d4f07a21d1c08084 -> 16
  stats: shared=0 unique=16 size=8.999MiB ratio=1.00

phase 0:
  docker.io zhouying7780/buxtest blobs=16 mounts=0 manifests=10 shared=0

info: Planning completed in 8.67s
uploading: docker.io/library/zhouying7780/buxtest sha256:b5a4eaa2659ece1708b67bb79c20a61a0fa3d00b9430ae0ad970ffb9ec085a05 694.3KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:a08f16ed68b26ecf1f02f9a0948f59060bce94ffee49f211eafdf840ed14fb4d 725.3KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:f9e04f2a560088ea8169cff8710b0edb5f319a0e10c160e26d98ef1ded50cccf 705.6KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:d7e28ec550a2d3b32ddcda19c9c3af704b8b39977c6956b8f209f0d8b7fd719c 2.5MiB
uploading: docker.io/library/zhouying7780/buxtest sha256:322973677ef5fb0405c230fed304b2e907f46a1edb921bab269f88547bcf726f 743.1KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:220602de6ed2e72ac3dead2002c03ab243dbaf27be9ed1b08b5588e52e4f20f1 796.8KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:3eb12473a8208b6631651bb118954a7ec551ae6343bd1fb19b5603338b629582 892KiB
uploading: docker.io/library/zhouying7780/buxtest sha256:6dc7af96dfc85a47644373a0b98e836fd0c8aff6b6356418cba4ea7b46afc039 2.038MiB
sha256:cce548084ce402540134267ae6b98a9ce9273fcb57c801e07daeca7de2b2222b docker.io/library/zhouying7780/buxtest
sha256:59d479d844385faca8e6abce4df3ff3bcb54cc3ab6e7a51838c75f91451311b5 docker.io/library/zhouying7780/buxtest
sha256:50edf1d080946c6a76989d1c3b0e753b62f7d9b5f5e66e88bef23ebbd1e9709c docker.io/library/zhouying7780/buxtest
sha256:362ea5ff976609d3a811e5423bd8c11e1f031ae90ee823b1e56362dfe1d16d87 docker.io/library/zhouying7780/buxtest
sha256:24fd20af232ca4ab5efbf1aeae7510252e2b60b15e9a78947467340607cd2ea2 docker.io/library/zhouying7780/buxtest
sha256:7044f6fc222ac87449d87e041eae6b5254012a8b4cbbc35e5b317ac61aa12557 docker.io/library/zhouying7780/buxtest
sha256:b19898c529964a48ce66923a06ddbde9cd5ae2472a42891b55cc00f7a60ba676 docker.io/library/zhouying7780/buxtest
sha256:7f0daf640bfd30871f64d8fe7d457931259b1c0aec5c929a8daabbe44c359337 docker.io/library/zhouying7780/buxtest
sha256:1828edd60c5efd34b2bf5dd3282ec0cc04d47b2ff9caa0b6d4f07a21d1c08084 docker.io/library/zhouying7780/buxtest:16
info: Mirroring completed in 21.58s (437.2kB/s)

Comment 4 errata-xmlrpc 2019-12-20 00:46:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4181


Note You need to log in before you can comment on or make changes to this bug.