Bug 1762155 - Review Request: opensubdiv - An Open-Source subdivision surface library
Summary: Review Request: opensubdiv - An Open-Source subdivision surface library
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1754797
TreeView+ depends on / blocked
 
Reported: 2019-10-16 04:04 UTC by Luya Tshimbalanga
Modified: 2019-11-13 09:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-09 21:20:44 UTC
Type: ---
negativo17: fedora-review+


Attachments (Terms of Use)

Description Luya Tshimbalanga 2019-10-16 04:04:37 UTC
Spec URL: https://copr-be.cloud.fedoraproject.org/results/luya/OpenSubdiv/fedora-31-x86_64/01059107-opensubdiv/opensubdiv.spec
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/luya/OpenSubdiv/fedora-31-x86_64/01059107-opensubdiv/opensubdiv-3.4.0-2.fc31.src.rpm
Description: 
OpenSubdiv is a set of open source libraries that implement high performance
subdivision surface (subdiv) evaluation on massively parallel CPU and
GPU architectures. 
This codepath is optimized for drawing deforming subdivs with static topology
at interactive framerates.
Fedora Account System Username: luya

Comment 1 Luya Tshimbalanga 2019-10-16 04:09:30 UTC
Note that, for some odd reason, the built failed to properly detect OpenCL provided by opencl-headers package.

Comment 2 Simone Caronni 2019-10-20 09:55:33 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

C/C++:
[ ]: Provides: bundled(gnulib) in place as required.
     Note: Sources not installed
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: If your application is a C or C++ application you must list a
     BuildRequires against gcc, gcc-c++ or clang.
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig not called in %post and %postun for Fedora 28 and later.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
[x]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Sources are verified with gpgverify first in %prep if upstream
     publishes signatures.
     Note: gpgverify is not used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Fully versioned dependency in subpackages if applicable.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: opensubdiv-3.4.0-2.fc32.x86_64.rpm
          opensubdiv-libs-3.4.0-2.fc32.x86_64.rpm
          opensubdiv-devel-3.4.0-2.fc32.x86_64.rpm
          opensubdiv-debuginfo-3.4.0-2.fc32.x86_64.rpm
          opensubdiv-debugsource-3.4.0-2.fc32.x86_64.rpm
          opensubdiv-3.4.0-2.fc32.src.rpm
opensubdiv.x86_64: W: spelling-error %description -l en_US subdiv -> sub div, sub-div, subdivide
opensubdiv.x86_64: W: spelling-error %description -l en_US codepath -> code path, code-path, codependent
opensubdiv.x86_64: W: spelling-error %description -l en_US subdivs -> subdivide
opensubdiv.x86_64: W: spelling-error %description -l en_US framerates -> frame rates, frame-rates, frustrates
opensubdiv.x86_64: W: no-documentation
opensubdiv.x86_64: W: no-manual-page-for-binary far_perf
opensubdiv.x86_64: W: no-manual-page-for-binary far_regression
opensubdiv.x86_64: W: no-manual-page-for-binary hbr_baseline
opensubdiv.x86_64: W: no-manual-page-for-binary hbr_regression
opensubdiv.x86_64: W: no-manual-page-for-binary osd_regression
opensubdiv.x86_64: W: no-manual-page-for-binary stringify
opensubdiv.src: W: spelling-error %description -l en_US subdiv -> sub div, sub-div, subdivide
opensubdiv.src: W: spelling-error %description -l en_US codepath -> code path, code-path, codependent
opensubdiv.src: W: spelling-error %description -l en_US subdivs -> subdivide
opensubdiv.src: W: spelling-error %description -l en_US framerates -> frame rates, frame-rates, frustrates
6 packages and 0 specfiles checked; 0 errors, 15 warnings.




Rpmlint (debuginfo)
-------------------
Checking: opensubdiv-debuginfo-3.4.0-2.fc32.x86_64.rpm
          opensubdiv-libs-debuginfo-3.4.0-2.fc32.x86_64.rpm
2 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
opensubdiv.x86_64: W: spelling-error %description -l en_US subdiv -> sub div, sub-div, subdivide
opensubdiv.x86_64: W: spelling-error %description -l en_US codepath -> code path, code-path, codependent
opensubdiv.x86_64: W: spelling-error %description -l en_US subdivs -> subdivide
opensubdiv.x86_64: W: spelling-error %description -l en_US framerates -> frame rates, frame-rates, frustrates
opensubdiv.x86_64: W: no-documentation
opensubdiv.x86_64: W: no-manual-page-for-binary far_perf
opensubdiv.x86_64: W: no-manual-page-for-binary far_regression
opensubdiv.x86_64: W: no-manual-page-for-binary hbr_baseline
opensubdiv.x86_64: W: no-manual-page-for-binary hbr_regression
opensubdiv.x86_64: W: no-manual-page-for-binary osd_regression
opensubdiv.x86_64: W: no-manual-page-for-binary stringify
6 packages and 0 specfiles checked; 0 errors, 11 warnings.



Source checksums
----------------
https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v3_4_0.tar.gz#/opensubdiv-3.4.0.tar.gz :
  CHECKSUM(SHA256) this package     : d932b292f83371c7518960b2135c7a5b931efb43cdd8720e0b27268a698973e4
  CHECKSUM(SHA256) upstream package : d932b292f83371c7518960b2135c7a5b931efb43cdd8720e0b27268a698973e4


Requires
--------
opensubdiv (rpmlib, GLIBC filtered):
    libGLEW.so.2.1()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libglfw.so.3()(64bit)
    libm.so.6()(64bit)
    libosdCPU.so.3.4.0()(64bit)
    libosdGPU.so.3.4.0()(64bit)
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(CXXABI_1.3.8)(64bit)
    libstdc++.so.6(CXXABI_1.3.9)(64bit)
    libtbbmalloc_proxy.so.2()(64bit)
    rtld(GNU_HASH)

opensubdiv-libs (rpmlib, GLIBC filtered):
    libGLEW.so.2.1()(64bit)
    libOpenGL.so.0()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libgomp.so.1()(64bit)
    libgomp.so.1(GOMP_4.0)(64bit)
    libgomp.so.1(OMP_1.0)(64bit)
    libm.so.6()(64bit)
    libosdCPU.so.3.4.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(CXXABI_1.3.8)(64bit)
    libstdc++.so.6(CXXABI_1.3.9)(64bit)
    libtbb.so.2()(64bit)
    libtbbmalloc_proxy.so.2()(64bit)
    opensubdiv(x86-64)
    rtld(GNU_HASH)

opensubdiv-devel (rpmlib, GLIBC filtered):
    libosdCPU.so.3.4.0()(64bit)
    libosdGPU.so.3.4.0()(64bit)
    opensubdiv(x86-64)

opensubdiv-debuginfo (rpmlib, GLIBC filtered):

opensubdiv-debugsource (rpmlib, GLIBC filtered):



Provides
--------
opensubdiv:
    opensubdiv
    opensubdiv(x86-64)

opensubdiv-libs:
    libosdCPU.so.3.4.0()(64bit)
    libosdGPU.so.3.4.0()(64bit)
    opensubdiv-libs
    opensubdiv-libs(x86-64)

opensubdiv-devel:
    opensubdiv-devel
    opensubdiv-devel(x86-64)

opensubdiv-debuginfo:
    debuginfo(build-id)
    opensubdiv-debuginfo
    opensubdiv-debuginfo(x86-64)

opensubdiv-debugsource:
    opensubdiv-debugsource
    opensubdiv-debugsource(x86-64)



Generated by fedora-review 0.7.3 (44b83c7) last change: 2019-09-18
Command line :/usr/bin/fedora-review -b 1762155
Buildroot used: fedora-rawhide-{{ target_arch }}
Active plugins: C/C++, Generic, Shell-api
Disabled plugins: Perl, Ocaml, PHP, Haskell, SugarActivity, R, fonts, Java, Python
Disabled flags: EPEL6, EPEL7, DISTTAG, BATCH, EXARCH

Comment 3 Simone Caronni 2019-10-20 09:56:06 UTC
Checking now if we can mark these:

[ ]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.

Comment 4 Simone Caronni 2019-10-20 10:05:35 UTC
Some small changes I would do:

--- opensubdiv.orig	2019-10-20 11:59:39.094062409 +0200
+++ opensubdiv.spec	2019-10-20 12:00:56.567593912 +0200
@@ -1,3 +1,5 @@
+%global upstream_version 3_4_0
+
 Name:           opensubdiv
 Version:        3.4.0
 Release:        2%{?dist}
@@ -5,7 +7,7 @@
 
 License:        ASL 2.0
 URL:            http://graphics.pixar.com/%{name}
-Source0:        https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v3_4_0.tar.gz#/%{name}-%{version}.tar.gz
+Source0:        https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v%{upstream_version}.tar.gz#/%{name}-%{version}.tar.gz
 
 BuildRequires:  cmake
 BuildRequires:  chrpath
@@ -42,7 +44,7 @@
 developing applications that use %{name}.
 
 %prep
-%autosetup -n OpenSubdiv-3_4_0
+%autosetup -n OpenSubdiv-%{upstream_version}
 
 %build
 %cmake \

This way you can replace versions at the top of the file in one go.

Comment 5 Simone Caronni 2019-10-20 10:06:02 UTC
--- CMakeLists.txt.orig	2019-10-20 12:02:15.905162264 +0200
+++ CMakeLists.txt	2019-10-20 12:02:24.873339548 +0200
@@ -140,10 +140,6 @@
     list(APPEND CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
 endif()
 
-# add the automatically determined parts of the RPATH
-# which point to directories outside the build tree to the install RPATH
-SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
-
 # ensure that ARC is shown as enabled in the Xcode UI
 if(CMAKE_GENERATOR STREQUAL "Xcode")
     set (CMAKE_XCODE_ATTRIBUTE_CLANG_ENABLE_OBJC_ARC "YES")

This patch removes the hardcoding of run path, so you can then remove the chrpath dependency and the commands in the %install section:

--- opensubdiv.orig	2019-10-20 12:01:50.401658109 +0200
+++ opensubdiv.spec	2019-10-20 12:04:37.162935199 +0200
@@ -10,7 +10,6 @@
 Source0:        https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v%{upstream_version}.tar.gz#/%{name}-%{version}.tar.gz
 
 BuildRequires:  cmake
-BuildRequires:  chrpath
 BuildRequires:  doxygen
 BuildRequires:  gcc-c++
 BuildRequires:  glew-devel
@@ -69,11 +68,7 @@
 %install
 %make_install
 
-# Remove rpaths
-chrpath --delete %{buildroot}%{_bindir}/*
-chrpath --delete %{buildroot}%{_libdir}/*.so*
-
-find %{buildroot} -name '*.la' -exec rm -f {} ';'
+find %{buildroot} -name '*.la' -delete
 
 # Remove static file .a
 rm -fr %{buildroot}%{_libdir}/*.a

Comment 6 Simone Caronni 2019-10-20 10:50:11 UTC
Wait a second, ignore the comment above. With a few more changes you can enable docs, examples, test, etc.

Comment 7 Simone Caronni 2019-10-20 12:00:09 UTC
So, this is to remove the installation of the run path at compilation time:

--- OpenSubdiv-3_4_0/CMakeLists.txt.orig	2019-10-20 12:02:15.905162264 +0200
+++ OpenSubdiv-3_4_0/CMakeLists.txt	2019-10-20 12:27:26.934582395 +0200
@@ -132,18 +132,6 @@
 endif()
 
 
-if (NOT CMAKE_COMPILER_IS_ICC)
-    # Currently icc has a bug that asserts when linking rpaths containing long
-    # sequences of ':' that this command causes. The consequence is that examples
-    # built and installed using icc will not have an rpath pointing to the built
-    # OSD library which they depend on and will have to set LD_LIBRARY_PATH instead.
-    list(APPEND CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
-endif()
-
-# add the automatically determined parts of the RPATH
-# which point to directories outside the build tree to the install RPATH
-SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
-
 # ensure that ARC is shown as enabled in the Xcode UI
 if(CMAKE_GENERATOR STREQUAL "Xcode")
     set (CMAKE_XCODE_ATTRIBUTE_CLANG_ENABLE_OBJC_ARC "YES")

And this is to:
- Building test and examples (also used in tests)
- Removing chrpath dependency
- Building documentation
- Setting the upstream version at the top of the file
- Explicitly declaring library versions (in case of ABI changes)
- Explicitly declaring binaries, differentiating between tutorials, tests and normal binaries; so you don't include all binaries in one place in case a new tutorial is added

Tests are still disabled, as glImaging and osd_regression require a GL context to run. Running them in Xvfb in the test section is not enough.

--- opensubdiv.orig	2019-10-20 12:06:07.693705361 +0200
+++ opensubdiv.spec	2019-10-20 13:52:56.161636038 +0200
@@ -8,6 +8,7 @@
 License:        ASL 2.0
 URL:            http://graphics.pixar.com/%{name}
 Source0:        https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v%{upstream_version}.tar.gz#/%{name}-%{version}.tar.gz
+Patch0:         %{name}-rpath.patch
 
 BuildRequires:  cmake
 BuildRequires:  doxygen
@@ -43,7 +44,7 @@
 developing applications that use %{name}.
 
 %prep
-%autosetup -n OpenSubdiv-%{upstream_version}
+%autosetup -p1 -n OpenSubdiv-%{upstream_version}
 
 %build
 %cmake \
@@ -52,39 +53,61 @@
        -DCMAKE_LIBDIR_BASE=%{_libdir} \
        -DGLEW_LOCATION=%{_libdir} \
        -DGLFW_LOCATION=%{_libdir} \
-       -DNO_DOC=1 \
-       -DNO_EXAMPLES=1  // disable examples build \
        -DNO_CUDA=1 \
        -DNO_GLFW_X11=1 // disable X11 dependencies\
        -DNO_PTEX=1 \
-       -DNO_TUTORIALS=1 \
        -DOPENCL_INCLUDE_DIRS=%{_includedir} \
        -DOpenGL_GL_PREFERENCE=GLVND \
        -DTBB_LOCATION=%{_libdir} \
      .
 %make_build
 
+%{?_with_tests:
+%check
+make test V=1
+}
 
 %install
 %make_install
 
-find %{buildroot} -name '*.la' -delete
+# Move tutorials out of subdirectory
+mv %{buildroot}%{_bindir}/tutorials/* %{buildroot}%{_bindir}/
+rm -fr %{buildroot}%{_bindir}/tutorials
+
+# Let rpmbuild pick up documentation
+rm -fr %{buildroot}%{_docdir}
 
-# Remove static file .a
-rm -fr %{buildroot}%{_libdir}/*.a
+find %{buildroot} -name '*.la' -delete
+find %{buildroot} -name '*.a' -delete
 
 %ldconfig_scriptlets
 
 %files
-%{_bindir}/*
+%{_bindir}/far_perf
+%{_bindir}/far_regression
+%{_bindir}/hbr_baseline
+%{_bindir}/hbr_regression
+%{_bindir}/osd_regression
+%{_bindir}/stringify
 
 %files libs
 %license LICENSE.txt
 %doc README.md
-%{_libdir}/*.so.*
+%{_libdir}/*.so.%{version}
 
 %files devel
-%doc NOTICE.txt
+%doc NOTICE.txt documentation/doxy_html
+%{_bindir}/farViewer
+%{_bindir}/glEvalLimit
+%{_bindir}/glFVarViewer
+%{_bindir}/glImaging
+%{_bindir}/glPaintTest
+%{_bindir}/glShareTopology
+%{_bindir}/glStencilViewer
+%{_bindir}/glViewer
+%{_bindir}/far_tutorial*
+%{_bindir}/hbr_tutorial*
+%{_bindir}/osd_tutorial*
 %{_includedir}/*
 %{_libdir}/*.so

Comment 8 Simone Caronni 2019-10-20 12:24:56 UTC
So please address Comment #4 and Comment #7, then we can check the rest.

We should also investigate these things during the Cmake run:

-- Could NOT find CLEW (missing: CLEW_INCLUDE_DIR CLEW_LIBRARY) 
-- Could NOT find OpenCL (missing: OPENCL_LIBRARIES) (Required is at least version "1.1")
-- Could NOT find Docutils (missing: RST2HTML_EXECUTABLE) (Required is at least version "0.9")
CMake Warning at CMakeLists.txt:494 (message):
  OpenCL was not found : support for OpenCL parallel compute kernels will be
  disabled in Osd.  If you have the OpenCL SDK installed, please refer to the
  FindOpenCL.cmake in /builddir/build/BUILD/OpenSubdiv-3_4_0/cmake.
-- Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "2.6")

Comment 9 Simone Caronni 2019-10-20 13:04:57 UTC
@luya example SPEC file which fixes all of the above except OpenCL is here: https://fedorapeople.org/~slaanesh/opensubdiv/


You can remove the ldconfig_scriptlets as this will not build under CentOS/RHEL 7.

Comment 10 Luya Tshimbalanga 2019-10-27 19:05:39 UTC
Here is the updated files

Spec URL: https://copr-be.cloud.fedoraproject.org/results/luya/OpenSubdiv/fedora-rawhide-x86_64/01080935-opensubdiv/opensubdiv.spec
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/luya/OpenSubdiv/fedora-rawhide-x86_64/01080935-opensubdiv/opensubdiv-3.4.0-3.fc32.src.rpm

The errors on Comment #8 notably python interpreter (which should be on 3.x as 2.7 is near end of life) and opencl seem upstream related.

Comment 11 Simone Caronni 2019-11-02 15:56:52 UTC
I think it's fine. Package approved.

Comment 12 Luya Tshimbalanga 2019-11-02 16:57:17 UTC
Thank you. Request for branching sent.

Comment 13 Gwyn Ciesla 2019-11-02 19:06:26 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/opensubdiv

Comment 14 Luya Tshimbalanga 2019-11-02 20:41:21 UTC
(In reply to Gwyn Ciesla from comment #13)
> (fedscm-admin):  The Pagure repository was created at
> https://src.fedoraproject.org/rpms/opensubdiv

Thanks for the quick answered request!

Comment 15 Fedora Update System 2019-11-04 06:32:30 UTC
FEDORA-2019-0e81289f8a has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e81289f8a

Comment 16 Fedora Update System 2019-11-05 00:47:23 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc30, alembic-1.7.12-1.fc30, blender-2.80-13.fc30, luxcorerender-2.2-6.fc30, opensubdiv-3.4.0-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e81289f8a

Comment 17 Fedora Update System 2019-11-05 01:25:44 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc31, alembic-1.7.12-1.fc31, blender-2.80-13.fc31, luxcorerender-2.2-6.fc31, opensubdiv-3.4.0-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a4ad651b93

Comment 18 Fedora Update System 2019-11-09 21:20:44 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc31, alembic-1.7.12-1.fc31, blender-2.80-13.fc31, luxcorerender-2.2-6.fc31, opensubdiv-3.4.0-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2019-11-13 09:56:17 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc30, alembic-1.7.12-1.fc30, blender-2.80-13.fc30, luxcorerender-2.2-6.fc30, opensubdiv-3.4.0-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.