Bug 1754797 - subdivision modifier doesn't work in Blender 2.8
Summary: subdivision modifier doesn't work in Blender 2.8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blender
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1766130 (view as bug list)
Depends On: 1762155
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-24 06:09 UTC by 汪明衡
Modified: 2019-11-13 09:56 UTC (History)
9 users (show)

Fixed In Version: blender-2.80-9.fc31 blender-2.80-9.fc30 blender-2.80-13.fc31 blender-2.80-13.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-09 21:20:51 UTC
Type: Bug


Attachments (Terms of Use)

Description 汪明衡 2019-09-24 06:09:55 UTC
Description of problem:
Subdivision surface doesn't work

Version-Release number of selected component (if applicable):
Blender 2.80 (sub 75)

How reproducible:
add subdivision surface to a mesh. If "apply" is clicked, there will be an error message saying "modifier return error, skipping apply".

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
It is said that this version of blender might not be built with opensubdiv.

Comment 1 Fedora Update System 2019-10-02 07:31:14 UTC
FEDORA-2019-93e6beaebd has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-93e6beaebd

Comment 2 Fedora Update System 2019-10-03 01:52:17 UTC
blender-2.80-9.fc30, embree-3.6.1-2.fc30, luxcorerender-2.2-1.fc30, openvdb-6.2.0-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b278a8162e

Comment 3 Fedora Update System 2019-10-03 03:19:41 UTC
blender-2.80-9.fc31, embree-3.6.1-2.fc31, ispc-1.12.0-2.fc31, luxcorerender-2.2-1.fc31, openvdb-6.2.0-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-93e6beaebd

Comment 4 Fedora Update System 2019-10-08 00:26:46 UTC
blender-2.80-9.fc31, embree-3.6.1-2.fc31, ispc-1.12.0-2.fc31, luxcorerender-2.2-1.fc31, openvdb-6.2.0-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2019-10-10 16:55:45 UTC
blender-2.80-9.fc30, embree-3.6.1-2.fc30, luxcorerender-2.2-1.fc30, openvdb-6.2.0-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Simone Caronni 2019-10-13 20:20:03 UTC
Seriously? The OpenSubdiv package is not even in Fedora, enabling the flag in Blender does not do anything!

-- Could NOT find OpenSubdiv (missing: _opensubdiv_LIBRARIES OPENSUBDIV_INCLUDE_DIR)
-- OpenSubdiv not found

Comment 7 Luya Tshimbalanga 2019-10-28 15:23:32 UTC
*** Bug 1766130 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2019-11-04 06:35:20 UTC
FEDORA-2019-0e81289f8a has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e81289f8a

Comment 9 Fedora Update System 2019-11-04 06:36:08 UTC
FEDORA-2019-a4ad651b93 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a4ad651b93

Comment 10 Fedora Update System 2019-11-05 00:47:28 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc30, alembic-1.7.12-1.fc30, blender-2.80-13.fc30, luxcorerender-2.2-6.fc30, opensubdiv-3.4.0-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e81289f8a

Comment 11 Fedora Update System 2019-11-05 01:25:48 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc31, alembic-1.7.12-1.fc31, blender-2.80-13.fc31, luxcorerender-2.2-6.fc31, opensubdiv-3.4.0-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a4ad651b93

Comment 12 Antoine Catton 2019-11-07 20:05:40 UTC
I was impacted by this bug.

I ran: sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2019-0e81289f8a

And the issue is fixed for me. I can add a subdivision modifier, and the viewport reflects the subdivision. (Before the fixed it was remaining unchanged) I can also apply the modifier. (Before the fix, I had an error)

Comment 13 Fedora Update System 2019-11-09 21:20:51 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc31, alembic-1.7.12-1.fc31, blender-2.80-13.fc31, luxcorerender-2.2-6.fc31, opensubdiv-3.4.0-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-11-13 09:56:22 UTC
YafaRay-3.3.0-25.20190819git0a182c1.fc30, alembic-1.7.12-1.fc30, blender-2.80-13.fc30, luxcorerender-2.2-6.fc30, opensubdiv-3.4.0-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.