Bug 176284 - Failed to bring up eth0.
Failed to bring up eth0.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 176334 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 15:36 EST by John Ellson
Modified: 2015-01-04 17:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 23:01:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output while running on kernel-2.6.14-1.1773_FC5 (1.89 KB, text/plain)
2005-12-20 15:39 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2005-12-20 15:36:23 EST
Description of problem:
During init I see:
  Bringing up interface eth0:  SIOCSIFFLAGS: Device or resource busy
  Failed to bring up eth0.

Nothing in dmesg or /var/log/messages that I could see.

Problem did not exist in 1773.

"service network restart" produces the same failure.


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1776_FC5
kernel-2.6.14-1.1777_FC5

How reproducible:
100%

Steps to Reproduce:
1.service network restart
2.
3.
  
Actual results:
  Bringing up interface eth0:  SIOCSIFFLAGS: Device or resource busy
  Failed to bring up eth0.

Expected results:


Additional info:
Comment 1 John Ellson 2005-12-20 15:38:17 EST
This is on a X86_64 box.  lspci output (while running 1773) follows.
Comment 2 John Ellson 2005-12-20 15:39:31 EST
Created attachment 122467 [details]
lspci output while running on kernel-2.6.14-1.1773_FC5
Comment 3 Michal Jaegermann 2005-12-20 21:32:22 EST
I am observing the same problem on i386 machine with the following layout of PCI:

-[0000:00]-+-00.0  Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System
Controller
           +-01.0-[0000:01]--
           +-07.0  Advanced Micro Devices [AMD] AMD-768 [Opus] ISA
           +-07.1  Advanced Micro Devices [AMD] AMD-768 [Opus] IDE
           +-07.3  Advanced Micro Devices [AMD] AMD-768 [Opus] ACPI
           \-10.0-[0000:02]--+-04.0  3Com Corporation 3c905C-TX/TX-M [Tornado]
                             +-06.0  ATI Technologies Inc Radeon RV100 QY
[Radeon 7000/VE]
                             +-07.0  OPTi Inc. 82C861
                             +-07.1  OPTi Inc. 82C861
                             \-08.0  3Com Corporation 3c905C-TX/TX-M [Tornado]

In dmesg I see:

ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 16 (level, low) -> IRQ 0
eth1: Could not reserve IRQ 0
eth1: Could not reserve IRQ 0
....

With an older kernel, where networking works, these are assigned to interrupts
169 and 177.  I see there in dmesg:

ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 16 (level, low) -> IRQ 169
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
0000:02:04.0: 3Com PCI 3c905C Tornado at e0840000. Vers LK1.1.19
ACPI: PCI Interrupt 0000:02:08.0[A] -> GSI 19 (level, low) -> IRQ 177
0000:02:08.0: 3Com PCI 3c905C Tornado at e0850400. Vers LK1.1.19

Both interrupts are actually shared with ohci_hcd.

With 2.6.14-1.1777_FC5 I have:

ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 16 (level, low) -> IRQ 177
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
0000:02:04.0: 3Com PCI 3c905C Tornado at e0876000. Vers LK1.1.19
.....
ACPI: PCI Interrupt 0000:02:07.1[B] -> GSI 16 (level, low) -> IRQ 0
ohci_hcd 0000:02:07.1: Found HC with no IRQ.  Check BIOS/PCI 0000:02:07.1
setup!ACPI: PCI interrupt for device 0000:02:07.1 disabled
ohci_hcd 0000:02:07.1: init 0000:02:07.1 fail, -19
ACPI: PCI Interrupt 0000:02:08.0[A] -> GSI 19 (level, low) -> IRQ 0
0000:02:08.0: 3Com PCI 3c905C Tornado at e083e400. Vers LK1.1.19
 *** Warning: IRQ 0 is unlikely to work! ***

and indeed it does not.
Comment 4 Michal Jaegermann 2005-12-20 22:23:03 EST
I can boot my machine with 2.6.14-1.1777_FC5 and a working network if I will
add 'acpi=off' to boot parameters.  Only then eth0 and eth1 are getting IRQs
10 and 5, respectively.  With pci=biosirq or pci=noacpi the machine will hang
in a boot sequence.

Comment 5 Horst H. von Brand 2005-12-21 08:40:49 EST
Same general symptoms here with 2.6.14-1.1776 and 1.1776. The system (1.1777) is
now for a while in "Starting system message bus"...
Comment 6 John Ellson 2005-12-21 09:01:16 EST
I was able to boot 1777 with eth0 by using:  acpi=off irqpoll

System doesn't seem vaery happy though.  I see in dmesg:

    sata_nv 0000:00:07.0: version 0.8
    PCI: Setting latency timer of device 0000:00:07.0 to 64
    ata1: SATA max UDMA/133 cmd 0x9F0 ctl 0xBF2 bmdma 0xF600 irq 11
    ata2: SATA max UDMA/133 cmd 0x970 ctl 0xB72 bmdma 0xF608 irq 11
    nv_sata: Primary device added
    nv_sata: Primary device removed
    nv_sata: Secondary device added
    nv_sata: Secondary device removed
    nv_sata: Primary device added
    nv_sata: Primary device removed
    nv_sata: Secondary device added
    (lots more of these)

    hda: cdrom_pc_intr: The drive appears confused (ireason = 0x01)

    Losing some ticks... checking if CPU frequency changed.
Comment 7 Benjmain Youngdahl 2005-12-21 10:49:36 EST
*** Bug 176334 has been marked as a duplicate of this bug. ***
Comment 8 Benjmain Youngdahl 2005-12-21 10:52:15 EST
Same problem on an x86_64 emachines laptop.  

Output of lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:0a.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
00:0c.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN
Controller (rev 03)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller
(rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
00:13.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]
Comment 9 Dave Jones 2005-12-23 23:01:50 EST
should be fixed in newer kernels (was a bad acpi update).

Note You need to log in before you can comment on or make changes to this bug.