Bug 1762979 - only 1 attempt at imagestreamimport for a failed, initial sample import
Summary: only 1 attempt at imagestreamimport for a failed, initial sample import
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks: 1763891
TreeView+ depends on / blocked
 
Reported: 2019-10-17 23:39 UTC by Gabe Montero
Modified: 2020-01-23 11:08 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1763891 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:08:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 188 0 'None' closed Bug 1762979: retry failed imagestream imports more than once 2021-02-06 21:44:31 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:08:40 UTC

Description Gabe Montero 2019-10-17 23:39:03 UTC
Description of problem:

If a samples imagestream fails its initial import, samples operator will retry the image import, but if that fails, no subsequent image imports are done.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Image import retries for failed sample imagestreams happen on the relist interval


Additional info:

Comment 1 Gabe Montero 2019-10-21 19:26:15 UTC
OK, this one is on the merge queue.

Some suggestions to QE for verification based on the manual testing I did:
1) corrupt the docker image ref for the spec of one of the openshift namespace imagestreams, like ruby's 2.5
2) confirm you start seeing image import failures in the samples operator config object .... not the last update time on that import error condition
3) you should also see messages in the samples operator pod logs around initiating an import 
4) if you let it sit for a bit, you should see messages in the pod logs about retrying , and the last update time of the import error condition changing, on a 10 to 15 minute interval
5) or course, if you fix the corrupted image image ref for ruby 2.5, you should see the import succeed, and the import error condition get cleared out.

Comment 3 XiuJuan Wang 2019-10-24 01:27:15 UTC
Verified with 4.3.0-0.nightly-2019-10-23-150053
When imports failed, imagestreams managed by samples operator will give more retry.

1.Tag imagestreamtag managed by samples operator to an unexisted image.
2.Check config.samples 
3.Check openshift-samples co
4.Check samples operator log

2.
    Message:               <imagestream/ruby>Internal error occurred: unknown: Not Found<imagestream/ruby><imagestream/php>Internal error occurred: unknown: Not Found<imagestream/php>
    Reason:                ruby php 
    Status:                True
    Type:                  ImportImageErrorsExist
3.
    Last Transition Time:  2019-10-24T01:18:12Z
    Message:               Samples installed at 4.3.0-0.nightly-2019-10-23-150053, with image import failures for these imagestreams: ruby php ; last import attempt 2019-10-24 01:18:08 +0000 UTC
    Reason:                FailedImageImports
    Status:                False
    Type:                  Progressing

4.
time="2019-10-24T01:07:10Z" level=info msg="imagestream ruby still not finished with its image imports, including spec tag 2.5 is at generation 5, but status tag 2.5 is at generation 2"
time="2019-10-24T01:07:11Z" level=info msg="aborting progress check (post-cache) for ruby because it has been removed from the image progress and import error conditions"
time="2019-10-24T01:07:11Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 6 failed with detailed message Internal error occurred: unknown: Not Found"
time="2019-10-24T01:07:12Z" level=info msg="initiated an imagestreamimport retry for imagestream/tag ruby/2.5"
time="2019-10-24T01:07:12Z" level=info msg="There are no more image imports in flight for imagestream ruby"
time="2019-10-24T01:07:12Z" level=info msg="CRDUPDATE updating progress/error condition after results for ruby"
time="2019-10-24T01:12:33Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 6 failed with detailed message Internal error occurred: unknown: Not Found"
time="2019-10-24T01:12:33Z" level=info msg="There are no more image imports in flight for imagestream ruby"
time="2019-10-24T01:13:20Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 6 failed with detailed message Internal error occurred: unknown: Not Found"
time="2019-10-24T01:13:20Z" level=info msg="There are no more image imports in flight for imagestream ruby"
time="2019-10-24T01:23:20Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 6 failed with detailed message Internal error occurred: unknown: Not Found"
time="2019-10-24T01:23:20Z" level=info msg="There are no more image imports in flight for imagestream ruby"

Comment 5 errata-xmlrpc 2020-01-23 11:08:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.