Bug 1763891 - only 1 attempt at imagestreamimport for a failed, initial sample import
Summary: only 1 attempt at imagestreamimport for a failed, initial sample import
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 1762979
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-21 20:23 UTC by Gabe Montero
Modified: 2019-11-13 18:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1762979
Environment:
Last Closed: 2019-11-13 18:56:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 189 0 'None' closed [release-4.2] Bug 1763891: retry failed imagestream imports more than once 2020-09-11 08:23:43 UTC
Red Hat Product Errata RHBA-2019:3303 0 None None None 2019-11-13 18:56:13 UTC

Description Gabe Montero 2019-10-21 20:23:28 UTC
+++ This bug was initially created as a clone of Bug #1762979 +++

Description of problem:

If a samples imagestream fails its initial import, samples operator will retry the image import, but if that fails, no subsequent image imports are done.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Image import retries for failed sample imagestreams happen on the relist interval


Additional info:

--- Additional comment from Gabe Montero on 2019-10-21 19:26:15 UTC ---

OK, this one is on the merge queue.

Some suggestions to QE for verification based on the manual testing I did:
1) corrupt the docker image ref for the spec of one of the openshift namespace imagestreams, like ruby's 2.5
2) confirm you start seeing image import failures in the samples operator config object .... not the last update time on that import error condition
3) you should also see messages in the samples operator pod logs around initiating an import 
4) if you let it sit for a bit, you should see messages in the pod logs about retrying , and the last update time of the import error condition changing, on a 10 to 15 minute interval
5) or course, if you fix the corrupted image image ref for ruby 2.5, you should see the import succeed, and the import error condition get cleared out.

Comment 1 Gabe Montero 2019-10-21 20:25:34 UTC
awaiting 4.3 PR/bugzilla to get verified by QE ... once done, will bugzilla refresh https://github.com/openshift/cluster-samples-operator/pull/189

Comment 3 XiuJuan Wang 2019-10-28 06:53:03 UTC
Verified with 4.2.0-0.nightly-2019-10-27-140004
When imports failed, imagestreams managed by samples operator will retry more times

1.Tag imagestreamtag managed by samples operator to an unexisted image.
2.Check config.samples 
3.Check openshift-samples co
4.Check samples operator log

    Last Transition Time:  2019-10-28T06:50:56Z
    Message:               Samples installed at 4.2.0-0.nightly-2019-10-27-140004, with image import failures for these imagestreams: ruby ; last import attempt 2019-10-28 06:23:53 +0000 UTC
    Reason:                FailedImageImports
    Status:                False
    Type:                  Progressing


time="2019-10-28T06:23:53Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 4 failed with detailed message Internal error occurred: unknown: Not Found"
time="2019-10-28T06:23:55Z" level=info msg="initiated an imagestreamimport retry for imagestream/tag ruby/2.5"
time="2019-10-28T06:23:55Z" level=info msg="There are no more image imports in flight for imagestream ruby"
time="2019-10-28T06:23:55Z" level=info msg="CRDUPDATE updating progress/error condition after results for ruby"
time="2019-10-28T06:30:06Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 4 failed with detailed message Internal error occurred: unknown: Not Found"
time="2019-10-28T06:30:06Z" level=info msg="There are no more image imports in flight for imagestream ruby"
time="2019-10-28T06:40:06Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 4 failed with detailed message Internal error occurred: unknown: Not Found"

Comment 5 errata-xmlrpc 2019-11-13 18:56:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3303


Note You need to log in before you can comment on or make changes to this bug.