Bug 176313 - libX11-devel should depend on libXau-devel and libXdmcp-devel
libX11-devel should depend on libXau-devel and libXdmcp-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 176079 (view as bug list)
Depends On:
Blocks: 171491 FC5Blocker
  Show dependency treegraph
 
Reported: 2005-12-21 04:56 EST by Roy-Magne Mo
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-24 01:54:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy-Magne Mo 2005-12-21 04:56:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
Installing gtk2-devel-2.8.9-1.1 fails to pull to in  libXau-devel and libXdmcp-devel (via yum).

Version-Release number of selected component (if applicable):
gtk2-devel-2.8.9-1.1

How reproducible:
Always

Steps to Reproduce:
1. yum install gtk2-devel 
2.
3.
  

Actual Results:  [root@localhost gaim-1.5.0]# /usr/bin/pkg-config --cflags gtk+-2.0
Package xau was not found in the pkg-config search path.
Perhaps you should add the directory containing `xau.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xau', required by 'X11', not found


Expected Results:  [root@localhost gaim-1.5.0]# /usr/bin/pkg-config --cflags gtk+-2.0 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include


Additional info:

rawhide updated as of 21. december 2005
Comment 1 Matthias Clasen 2005-12-21 08:42:35 EST
Thats a problem with libX11-devel, since the xau and xdmcp are private requirements.
Comment 2 Mike A. Harris 2005-12-21 11:44:09 EST
*** Bug 176079 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2005-12-23 16:54:09 EST
The next build of libX11 will fix this issue.
Comment 4 Mike A. Harris 2005-12-24 01:54:25 EST
Fixed in libX11-1.0.0-2 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.